summarylogtreecommitdiffstats
path: root/0003-intel-tbb-needs-new-cpp-std-and-ld-lookup.patch
diff options
context:
space:
mode:
authorbrainpower2015-06-16 23:20:37 +0200
committerbrainpower2015-06-16 23:20:37 +0200
commitf21de6dad42954a5ebd062666259a00b701e33e0 (patch)
tree24a825ac6d3ebf677e23cb0555af363a99ddd4c3 /0003-intel-tbb-needs-new-cpp-std-and-ld-lookup.patch
downloadaur-f21de6dad42954a5ebd062666259a00b701e33e0.tar.gz
create dosbox-daum with version 20150103
Diffstat (limited to '0003-intel-tbb-needs-new-cpp-std-and-ld-lookup.patch')
-rw-r--r--0003-intel-tbb-needs-new-cpp-std-and-ld-lookup.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/0003-intel-tbb-needs-new-cpp-std-and-ld-lookup.patch b/0003-intel-tbb-needs-new-cpp-std-and-ld-lookup.patch
new file mode 100644
index 000000000000..111251cec5de
--- /dev/null
+++ b/0003-intel-tbb-needs-new-cpp-std-and-ld-lookup.patch
@@ -0,0 +1,22 @@
+--- configure.ac.origin 2015-06-16 00:12:39.664253351 +0200
++++ configure.ac 2015-06-16 02:26:08.926218940 +0200
+@@ -19,6 +19,11 @@
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+
++dnl Add c++14 flag needed for intel-tbb
++CXXFLAGS="$CXXFLAGS -std=c++14"
++LDFLAGS="$LDFLAGS -std=c++14"
++LIBS="$LIBS -ltbb"
++
+ dnl Some needed libaries for OS2
+ dnl perharps join this with the other target depended checks. move them upwards
+ if test x$host = xi386-pc-os2-emx ; then
+@@ -593,6 +598,7 @@
+ AM_CONDITIONAL(HAVE_WINDRES, test "x$WINDRES" != "x:")
+ AC_SUBST(WINDRES)
+
++LIBS="$LIBS cpu/libcpu.a"
+
+ AC_CONFIG_FILES([
+ Makefile