summarylogtreecommitdiffstats
path: root/0003-libpsl-static-libs.patch
diff options
context:
space:
mode:
authorNicola Murino2024-02-19 14:04:36 +0100
committerNicola Murino2024-02-19 14:04:36 +0100
commit87c8b4c3148090538a3e07eb1096ee4679f44ab1 (patch)
treedd7036899e386c25126592702b03d2499391a3c1 /0003-libpsl-static-libs.patch
parent62075fdfd797c61efa0a558dfb9a6f3607ca310e (diff)
downloadaur-87c8b4c3148090538a3e07eb1096ee4679f44ab1.tar.gz
8.6.0
Diffstat (limited to '0003-libpsl-static-libs.patch')
-rw-r--r--0003-libpsl-static-libs.patch22
1 files changed, 10 insertions, 12 deletions
diff --git a/0003-libpsl-static-libs.patch b/0003-libpsl-static-libs.patch
index ce33b87eedb5..71e7efd5e115 100644
--- a/0003-libpsl-static-libs.patch
+++ b/0003-libpsl-static-libs.patch
@@ -1,16 +1,14 @@
---- curl-7.64.1.orig/configure.ac 2019-03-29 18:14:22.692813700 -0400
-+++ curl-7.64.1/configure.ac 2019-03-29 18:52:44.514352300 -0400
-@@ -2747,14 +2747,30 @@
- with_libpsl=$withval,
+--- curl-8.6.0/configure.ac.orig 2024-01-31 08:31:51.163839600 +0100
++++ curl-8.6.0/configure.ac 2024-01-31 08:33:39.021970100 +0100
+@@ -2059,12 +2059,30 @@
with_libpsl=yes)
+ curl_psl_msg="no (libpsl disabled)"
if test $with_libpsl != "no"; then
- AC_SEARCH_LIBS(psl_builtin, psl,
- [curl_psl_msg="enabled";
- AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
- ],
-- [curl_psl_msg="no (libpsl not found)";
-- AC_MSG_WARN([libpsl was not found])
-- ]
+- [AC_MSG_ERROR([libpsl was not found]) ]
- )
+ CURL_CHECK_PKGCONFIG(libpsl)
+ if test "$PKGCONFIG" != "no" ; then
@@ -27,12 +25,12 @@
+ else
+ dnl no nghttp2 pkg-config found, deal with it
+ AC_SEARCH_LIBS(psl_builtin, psl,
-+ [curl_psl_msg="enabled";
-+ AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
-+ ],
++ [curl_psl_msg="yes";
++ AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
++ ],
+ [curl_psl_msg="no (libpsl not found)";
-+ AC_MSG_WARN([libpsl was not found])
-+ ]
++ AC_MSG_WARN([libpsl was not found])
++ ]
+ )
+ fi
+