summarylogtreecommitdiffstats
path: root/0003-no-work-stealing.diff
diff options
context:
space:
mode:
authorayekat2018-12-08 00:19:54 +0100
committerayekat2018-12-08 00:19:54 +0100
commit4c7bfe92b88cf9b45f8246c6a04584196924ec8c (patch)
tree3ca0ab9f82fe494886077035d6293d9a12caefb1 /0003-no-work-stealing.diff
parentaa750c4f20af4011060436f07bbfda53a1ab7644 (diff)
downloadaur-4c7bfe92b88cf9b45f8246c6a04584196924ec8c.tar.gz
Initial overhaul after adopting
Upstream: * Use native libev rather than the one bundled with upstream (no libfiber-specific changes have been applied there anyway). * Use the `dist` scheduler rather than `wsd` (work-stealing): the latter schedules fibers in a rather bizarre way (keeps jumping back and forth between the last to fibers created, and never schedules any of the others). This may require further investigation. Downstream: * Fix license information: it's ISC. * Install headers and pkgconf files as well. * Add gitignore file to ignore build artifacts (except package files).
Diffstat (limited to '0003-no-work-stealing.diff')
-rw-r--r--0003-no-work-stealing.diff11
1 files changed, 11 insertions, 0 deletions
diff --git a/0003-no-work-stealing.diff b/0003-no-work-stealing.diff
new file mode 100644
index 000000000000..a184b2dd2675
--- /dev/null
+++ b/0003-no-work-stealing.diff
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -17,7 +17,7 @@ CFILES = \
+ hazard_pointer.c \
+ work_stealing_deque.c \
+ work_queue.c \
+- fiber_scheduler_wsd.c \
++ fiber_scheduler_dist.c \
+
+ USE_NATIVE_EVENTS ?= 1
+ ifeq ($(USE_NATIVE_EVENTS),1)