summarylogtreecommitdiffstats
path: root/0005-Makefile-disallow-data-races-on-gcc-10-as-well.patch
diff options
context:
space:
mode:
authorgraysky2020-05-10 16:13:26 -0400
committergraysky2020-05-10 16:13:26 -0400
commit626606b33883fa1f68644a125ba837fcc2f456b6 (patch)
treebc1511cec6b356bcd877e786e9d2afc2961ce88c /0005-Makefile-disallow-data-races-on-gcc-10-as-well.patch
parentbdbb369a2f149e9a569759c21303cfa2fac6fdd7 (diff)
downloadaur-626606b33883fa1f68644a125ba837fcc2f456b6.tar.gz
Update to 5.6.12-1
Diffstat (limited to '0005-Makefile-disallow-data-races-on-gcc-10-as-well.patch')
-rw-r--r--0005-Makefile-disallow-data-races-on-gcc-10-as-well.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/0005-Makefile-disallow-data-races-on-gcc-10-as-well.patch b/0005-Makefile-disallow-data-races-on-gcc-10-as-well.patch
new file mode 100644
index 000000000000..ab9fb3dd255a
--- /dev/null
+++ b/0005-Makefile-disallow-data-races-on-gcc-10-as-well.patch
@@ -0,0 +1,32 @@
+From 9d03a04a2d7097afd3c177e8125e7b65e2d26102 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Tue, 17 Mar 2020 00:07:18 +0000
+Subject: [PATCH 5/7] Makefile: disallow data races on gcc-10 as well
+
+gcc-10 will rename --param=allow-store-data-races=0
+to -fno-allow-store-data-races.
+
+The flag change happened at https://gcc.gnu.org/PR92046.
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+Acked-by: Jiri Kosina <jkosina@suse.cz>
+Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
+---
+ Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile b/Makefile
+index 97e4c4d9ac95..5ee8b2d86bab 100644
+--- a/Makefile
++++ b/Makefile
+@@ -714,6 +714,7 @@ endif
+
+ # Tell gcc to never replace conditional load with a non-conditional one
+ KBUILD_CFLAGS += $(call cc-option,--param=allow-store-data-races=0)
++KBUILD_CFLAGS += $(call cc-option,-fno-allow-store-data-races)
+
+ include scripts/Makefile.kcov
+ include scripts/Makefile.gcc-plugins
+--
+2.26.2
+