summarylogtreecommitdiffstats
path: root/0005-cmake-gcc-disable-Werror-maybe-uninitialized-for-GCC.patch
diff options
context:
space:
mode:
authorRobert Falkenberg2022-11-14 12:01:54 +0100
committerRobert Falkenberg2022-11-14 12:01:54 +0100
commitd75cbd05398a52998f220c58353413b7c3ed62cd (patch)
tree9e045671b74f80e4a9629a411db895bf79e45243 /0005-cmake-gcc-disable-Werror-maybe-uninitialized-for-GCC.patch
parent9c1b7d48a2b09f4cae51036d7e3b5689b542af00 (diff)
downloadaur-srsran-git.tar.gz
Update to 22.10.0
Diffstat (limited to '0005-cmake-gcc-disable-Werror-maybe-uninitialized-for-GCC.patch')
-rw-r--r--0005-cmake-gcc-disable-Werror-maybe-uninitialized-for-GCC.patch32
1 files changed, 0 insertions, 32 deletions
diff --git a/0005-cmake-gcc-disable-Werror-maybe-uninitialized-for-GCC.patch b/0005-cmake-gcc-disable-Werror-maybe-uninitialized-for-GCC.patch
deleted file mode 100644
index e48bb01480bf..000000000000
--- a/0005-cmake-gcc-disable-Werror-maybe-uninitialized-for-GCC.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 21a4a675dd74167552e6c78de432cd627e395481 Mon Sep 17 00:00:00 2001
-From: Robert Falkenberg <robert.falkenberg@srs.io>
-Date: Tue, 17 May 2022 15:10:41 +0200
-Subject: [PATCH] cmake/gcc: disable [-Werror=maybe-uninitialized] for GCC >=
- 12.1.0
-
-With GCC 12.1.0 there are numerous false-positive warnings on
-"maybe uninitialized" variables.
----
- CMakeLists.txt | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 664cadb94..694b6373a 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -540,6 +540,12 @@ if(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.0)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
- endif()
-
-+# GCC >= 12.1.0: Disable analysis on "maybe-uninitialized" variables because of the high false-positive rate
-+if(CMAKE_COMPILER_IS_GNUCXX AND NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 12.1)
-+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-maybe-uninitialized")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-maybe-uninitialized")
-+endif()
-+
- if(CMAKE_C_COMPILER_ID MATCHES "GNU")
- # Increase inlining limit to allow gcc compilation on e.g. RPi2
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} --param large-function-growth=1600")
---
-2.36.1
-