summarylogtreecommitdiffstats
path: root/0007-silence-compiler-warnings.patch
diff options
context:
space:
mode:
authorhowetuft2022-05-22 09:01:14 +0200
committerhowetuft2022-05-22 09:01:14 +0200
commit257979095aebbb849dba03ab426805c80d673676 (patch)
tree0996f0c9143dc87975a8e95f7536654ea43265ca /0007-silence-compiler-warnings.patch
parent0de343dc4c12c0aa46dbf91fab68200ac8796ac0 (diff)
downloadaur-257979095aebbb849dba03ab426805c80d673676.tar.gz
Fixes
Diffstat (limited to '0007-silence-compiler-warnings.patch')
-rw-r--r--0007-silence-compiler-warnings.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/0007-silence-compiler-warnings.patch b/0007-silence-compiler-warnings.patch
new file mode 100644
index 000000000000..a056a7d4474b
--- /dev/null
+++ b/0007-silence-compiler-warnings.patch
@@ -0,0 +1,24 @@
+From 905c132fe054804cea3897d33c222a33bc41142d Mon Sep 17 00:00:00 2001
+From: howetuft <howetuft@gmail.com>
+Date: Sat, 21 May 2022 18:19:13 +0200
+Subject: [PATCH 07/12] silence-compiler-warnings
+
+---
+ CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 78316b671..74f5465ef 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -45,6 +45,7 @@ unset(CMAKE_CONFIGURATION_TYPES CACHE)
+ # This boots up the generator:
+ enable_language(C)
+ enable_language(CXX)
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -w")
+
+ if (CMAKE_CONFIGURATION_TYPES)
+
+--
+2.36.1
+