summarylogtreecommitdiffstats
path: root/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
diff options
context:
space:
mode:
authorMartchus2021-09-02 16:05:24 +0200
committerMartchus2021-09-02 16:05:24 +0200
commit09f01e9025a3bb12e98ff0ba50996657bf453eca (patch)
tree50beb8177720e828e75116b408f4d48ef22e8c23 /0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
parent7d34d1b984dca091d928dcc261e742115f10b1d3 (diff)
downloadaur-09f01e9025a3bb12e98ff0ba50996657bf453eca.tar.gz
Update to 6.1.3
Diffstat (limited to '0008-Fix-crashes-in-rasterization-code-using-setjmp.patch')
-rw-r--r--0008-Fix-crashes-in-rasterization-code-using-setjmp.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch b/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
index 046ada39d8fd..2348941bb833 100644
--- a/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
+++ b/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
@@ -1,4 +1,4 @@
-From 8e627fbe4ab9331b587ec6a3c799934877a5c8d5 Mon Sep 17 00:00:00 2001
+From 4f351792812f2ad38743702ccffa6ccc7e5114da Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 26 Jun 2021 22:24:12 +0200
Subject: [PATCH 8/8] Fix crashes in rasterization code using setjmp
@@ -28,7 +28,7 @@ Change-Id: I01937d13569dd01ab4cb1f608020544c93bc343c
rename src/gui/painting/{qgrayraster.c => qgrayraster.cpp} (98%)
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
-index bb21d1b976..0d9ade29b9 100644
+index bb21d1b976..6a14076d55 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -166,7 +166,7 @@ qt_internal_add_module(Gui
@@ -46,7 +46,7 @@ index bb21d1b976..0d9ade29b9 100644
+# enable exceptions for painting/qgrayraster.cpp
+set_source_files_properties("painting/qgrayraster.cpp"
-+ PROPERTIES COMPILE_FLAGS "-fexceptions" DISABLE_PRECOMPILE_HEADERS ON SKIP_PRECOMPILE_HEADERS ON
++ PROPERTIES COMPILE_FLAGS "-fexceptions"
+)
+
# Resources:
@@ -248,5 +248,5 @@ index e2326a56c1..7b30969ec8 100644
"Description": "FreeType is a freely available software library to render fonts.",
"Homepage": "http://www.freetype.org",
--
-2.32.0
+2.33.0