summarylogtreecommitdiffstats
path: root/0009-USB-Armory-MkII-support.patch
diff options
context:
space:
mode:
authorDaniel Bermond2020-06-16 12:57:13 +0000
committerDaniel Bermond2020-06-16 12:57:13 +0000
commit018ee12649da3c5d1671e186d27e03b968c4250f (patch)
treefc404486678d335fdf1b41cf0f8ea79cfa5961cf /0009-USB-Armory-MkII-support.patch
parenta25c1f096f12a77d149ee65e1c8b17dda4ab9df7 (diff)
downloadaur-018ee12649da3c5d1671e186d27e03b968c4250f.tar.gz
Updated to version 5.7.2
Diffstat (limited to '0009-USB-Armory-MkII-support.patch')
-rw-r--r--0009-USB-Armory-MkII-support.patch26
1 files changed, 13 insertions, 13 deletions
diff --git a/0009-USB-Armory-MkII-support.patch b/0009-USB-Armory-MkII-support.patch
index 0bd885344fab..cce232ad09fe 100644
--- a/0009-USB-Armory-MkII-support.patch
+++ b/0009-USB-Armory-MkII-support.patch
@@ -1,4 +1,4 @@
-From 849c3ad55d9fcf00cb909e8f19139b939a22132c Mon Sep 17 00:00:00 2001
+From b492240828db14302661adcdd3fd12396069ee4e Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 11 Aug 2019 12:34:17 -0600
Subject: [PATCH 9/9] USB Armory MkII support
@@ -12,10 +12,10 @@ Subject: [PATCH 9/9] USB Armory MkII support
create mode 100644 arch/arm/boot/dts/imx6ull-usbarmory.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index 9f10323ecfde..ab24e8e9d0c2 100644
+index 6107ad410109..fd8e1835deb7 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
-@@ -585,10 +585,12 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
+@@ -609,10 +609,12 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
imx6ul-tx6ul-0010.dtb \
imx6ul-tx6ul-0011.dtb \
imx6ul-tx6ul-mainboard.dtb \
@@ -30,13 +30,13 @@ index 9f10323ecfde..ab24e8e9d0c2 100644
imx6ull-phytec-segin-lc-rdk-nand.dtb \
diff --git a/arch/arm/boot/dts/imx6ul-usbarmory.dts b/arch/arm/boot/dts/imx6ul-usbarmory.dts
new file mode 100644
-index 000000000000..3936ef8a64f1
+index 000000000000..f26344965ae1
--- /dev/null
+++ b/arch/arm/boot/dts/imx6ul-usbarmory.dts
@@ -0,0 +1,255 @@
+/*
+ * USB armory Mk II device tree file
-+ * https://inversepath.com/usbarmory
++ * https://github.com/inversepath/usbarmory
+ *
+ * Copyright (C) 2019, F-Secure Corporation
+ * Andrej Rosano <andrej.rosano@f-secure.com>
@@ -227,7 +227,7 @@ index 000000000000..3936ef8a64f1
+};
+
+&aips2 {
-+ crypto: caam@2140000 {
++ crypto: crypto@2140000 {
+ compatible = "fsl,imx6ul-caam", "fsl,sec-v4.0";
+ #address-cells = <1>;
+ #size-cells = <1>;
@@ -238,18 +238,18 @@ index 000000000000..3936ef8a64f1
+ <&clks IMX6UL_CLK_CAAM_MEM>;
+ clock-names = "ipg", "aclk", "mem";
+
-+ sec_jr0: jr0@1000 {
++ sec_jr0: jr@1000 {
+ compatible = "fsl,sec-v4.0-job-ring";
+ reg = <0x1000 0x1000>;
+ interrupts = <GIC_SPI 105 IRQ_TYPE_LEVEL_HIGH>;
+ };
+
-+ sec_jr1: jr1@2000 {
++ sec_jr1: jr@2000 {
+ compatible = "fsl,sec-v4.0-job-ring";
+ reg = <0x2000 0x1000>;
+ interrupts = <GIC_SPI 106 IRQ_TYPE_LEVEL_HIGH>;
+ };
-+ sec_jr2: jr2@3000 {
++ sec_jr2: jr@3000 {
+ compatible = "fsl,sec-v4.0-job-ring";
+ reg = <0x3000 0x1000>;
+ interrupts = <GIC_SPI 46 IRQ_TYPE_LEVEL_HIGH>;
@@ -277,7 +277,7 @@ index 000000000000..3936ef8a64f1
+};
+
+&usbotg1 {
-+ dr_mode = "otg";
++ dr_mode = "peripheral";
+ disable-over-current;
+ tpl-support;
+ status = "okay";
@@ -291,13 +291,13 @@ index 000000000000..3936ef8a64f1
+};
diff --git a/arch/arm/boot/dts/imx6ull-usbarmory.dts b/arch/arm/boot/dts/imx6ull-usbarmory.dts
new file mode 100644
-index 000000000000..85cf30bff527
+index 000000000000..2d758a805264
--- /dev/null
+++ b/arch/arm/boot/dts/imx6ull-usbarmory.dts
@@ -0,0 +1,256 @@
+/*
+ * USB armory Mk II device tree file
-+ * https://inversepath.com/usbarmory
++ * https://github.com/inversepath/usbarmory
+ *
+ * Copyright (C) 2019, F-Secure Corporation
+ * Andrej Rosano <andrej.rosano@f-secure.com>
@@ -552,5 +552,5 @@ index 000000000000..85cf30bff527
+ status = "okay";
+};
--
-2.23.0
+2.26.1