summarylogtreecommitdiffstats
path: root/0009-USB-Armory-MkII-support.patch
diff options
context:
space:
mode:
authorDaniel Bermond2020-08-26 01:04:37 +0000
committerDaniel Bermond2020-08-26 01:04:37 +0000
commitdb4999c6caf8a833055fe9c3561f4d97c2df672f (patch)
tree8ecb8e35b0095d222839147e7108ca234edcefef /0009-USB-Armory-MkII-support.patch
parentad2cbcfe6c3dbceb47932e9b3c62f320bdf6eab1 (diff)
downloadaur-db4999c6caf8a833055fe9c3561f4d97c2df672f.tar.gz
Updated to version 5.8.3
Diffstat (limited to '0009-USB-Armory-MkII-support.patch')
-rw-r--r--0009-USB-Armory-MkII-support.patch24
1 files changed, 13 insertions, 11 deletions
diff --git a/0009-USB-Armory-MkII-support.patch b/0009-USB-Armory-MkII-support.patch
index cce232ad09fe..647b88e4e599 100644
--- a/0009-USB-Armory-MkII-support.patch
+++ b/0009-USB-Armory-MkII-support.patch
@@ -1,21 +1,21 @@
-From b492240828db14302661adcdd3fd12396069ee4e Mon Sep 17 00:00:00 2001
+From 41a51f04b4267cc0491c54c7ddf68d88d344b74b Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 11 Aug 2019 12:34:17 -0600
Subject: [PATCH 9/9] USB Armory MkII support
---
arch/arm/boot/dts/Makefile | 2 +
- arch/arm/boot/dts/imx6ul-usbarmory.dts | 255 +++++++++++++++++++++++
- arch/arm/boot/dts/imx6ull-usbarmory.dts | 256 ++++++++++++++++++++++++
- 3 files changed, 513 insertions(+)
+ arch/arm/boot/dts/imx6ul-usbarmory.dts | 256 +++++++++++++++++++++++
+ arch/arm/boot/dts/imx6ull-usbarmory.dts | 257 ++++++++++++++++++++++++
+ 3 files changed, 515 insertions(+)
create mode 100644 arch/arm/boot/dts/imx6ul-usbarmory.dts
create mode 100644 arch/arm/boot/dts/imx6ull-usbarmory.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index 6107ad410109..fd8e1835deb7 100644
+index 42d24fced58b..9f6833189962 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
-@@ -609,10 +609,12 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
+@@ -614,10 +614,12 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
imx6ul-tx6ul-0010.dtb \
imx6ul-tx6ul-0011.dtb \
imx6ul-tx6ul-mainboard.dtb \
@@ -30,10 +30,10 @@ index 6107ad410109..fd8e1835deb7 100644
imx6ull-phytec-segin-lc-rdk-nand.dtb \
diff --git a/arch/arm/boot/dts/imx6ul-usbarmory.dts b/arch/arm/boot/dts/imx6ul-usbarmory.dts
new file mode 100644
-index 000000000000..f26344965ae1
+index 000000000000..1fdcd6f611d5
--- /dev/null
+++ b/arch/arm/boot/dts/imx6ul-usbarmory.dts
-@@ -0,0 +1,255 @@
+@@ -0,0 +1,256 @@
+/*
+ * USB armory Mk II device tree file
+ * https://github.com/inversepath/usbarmory
@@ -93,6 +93,7 @@ index 000000000000..f26344965ae1
+ };
+
+ memory {
++ device_type = "memory";
+ reg = <0x80000000 0x20000000>;
+ };
+
@@ -291,10 +292,10 @@ index 000000000000..f26344965ae1
+};
diff --git a/arch/arm/boot/dts/imx6ull-usbarmory.dts b/arch/arm/boot/dts/imx6ull-usbarmory.dts
new file mode 100644
-index 000000000000..2d758a805264
+index 000000000000..f74d0296d5f6
--- /dev/null
+++ b/arch/arm/boot/dts/imx6ull-usbarmory.dts
-@@ -0,0 +1,256 @@
+@@ -0,0 +1,257 @@
+/*
+ * USB armory Mk II device tree file
+ * https://github.com/inversepath/usbarmory
@@ -354,6 +355,7 @@ index 000000000000..2d758a805264
+ };
+
+ memory {
++ device_type = "memory";
+ reg = <0x80000000 0x20000000>;
+ };
+
@@ -552,5 +554,5 @@ index 000000000000..2d758a805264
+ status = "okay";
+};
--
-2.26.1
+2.27.0