summarylogtreecommitdiffstats
path: root/0011_use_system_gyp.patch
diff options
context:
space:
mode:
authorpat-s2018-03-04 20:19:56 +0100
committerpat-s2018-03-04 20:19:56 +0100
commiteca02c0286853717fb82b9f3a91b3c3ffbb7d6da (patch)
tree5149a1e3aedac0eb6c765ed09201f418a7f39eeb /0011_use_system_gyp.patch
parent8fb7d7687be1fdc6908573c8895b0d1ada9d5716 (diff)
downloadaur-eca02c0286853717fb82b9f3a91b3c3ffbb7d6da.tar.gz
update sources
Diffstat (limited to '0011_use_system_gyp.patch')
-rw-r--r--0011_use_system_gyp.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/0011_use_system_gyp.patch b/0011_use_system_gyp.patch
new file mode 100644
index 000000000000..c1527d2b6aae
--- /dev/null
+++ b/0011_use_system_gyp.patch
@@ -0,0 +1,23 @@
+Description: Use gyp package, not build/gyp/gyp.
+Forwarded: not-needed
+Author: Jérémy Lal <kapouer@melix.org>
+Last-Update: 2011-10-22
+--- a/Makefile
++++ b/Makefile
+@@ -250,14 +250,14 @@
+ OUT_MAKEFILES = $(addprefix $(OUTDIR)/Makefile.,$(ARCHES))
+ $(OUT_MAKEFILES): $(GYPFILES) $(ENVFILE)
+ GYP_GENERATORS=make \
+- build/gyp/gyp --generator-output="$(OUTDIR)" build/all.gyp \
++ gyp --generator-output="$(OUTDIR)" build/all.gyp \
+ -Ibuild/standalone.gypi --depth=. \
+ -Dv8_target_arch=$(subst .,,$(suffix $@)) \
+ -S.$(subst .,,$(suffix $@)) $(GYPFLAGS)
+
+ $(OUTDIR)/Makefile.native: $(GYPFILES) $(ENVFILE)
+ GYP_GENERATORS=make \
+- build/gyp/gyp --generator-output="$(OUTDIR)" build/all.gyp \
++ gyp --generator-output="$(OUTDIR)" build/all.gyp \
+ -Ibuild/standalone.gypi --depth=. -S.native $(GYPFLAGS)
+
+ must-set-ANDROID_NDK_ROOT_OR_TOOLCHAIN: