summarylogtreecommitdiffstats
path: root/0013-MINGW-configure-for-shared-build.patch
diff options
context:
space:
mode:
authoratomlong2021-10-23 17:55:22 +0800
committeratomlong2021-10-23 18:06:15 +0800
commit80096c8de4b34ec1ed8f30bb428918cd592b2424 (patch)
treeb48dd1e73de9ea35a4709fb6b93deb16331ec514 /0013-MINGW-configure-for-shared-build.patch
parent89a67c05174951d172252b1db96ff93cc4ec4bcd (diff)
downloadaur-mingw-w64-python.tar.gz
update to 3.9.7
Diffstat (limited to '0013-MINGW-configure-for-shared-build.patch')
-rw-r--r--0013-MINGW-configure-for-shared-build.patch69
1 files changed, 69 insertions, 0 deletions
diff --git a/0013-MINGW-configure-for-shared-build.patch b/0013-MINGW-configure-for-shared-build.patch
new file mode 100644
index 000000000000..43a074da2c61
--- /dev/null
+++ b/0013-MINGW-configure-for-shared-build.patch
@@ -0,0 +1,69 @@
+From ed8995bda0e5acd112b43ee5662df3640f6154f3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=D0=90=D0=BB=D0=B5=D0=BA=D1=81=D0=B5=D0=B9?=
+ <alexey.pawlow@gmail.com>
+Date: Thu, 17 Jun 2021 18:51:24 +0530
+Subject: [PATCH 013/N] MINGW configure for shared build
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Co-authored-by: Алексей <alexey.pawlow@gmail.com>
+---
+ configure.ac | 20 +++++++++++++++++++-
+ 1 file changed, 19 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 806ebe0..6ebf250 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1233,6 +1233,13 @@ if test $enable_shared = "yes"; then
+ ;;
+
+ esac
++ case $host in
++ *-*-mingw*)
++ LDLIBRARY='libpython$(LDVERSION).dll.a'
++ DLLLIBRARY='libpython$(LDVERSION).dll'
++ BLDLIBRARY='-L. -lpython$(LDVERSION)'
++ ;;
++ esac
+ else # shared is disabled
+ PY_ENABLE_SHARED=0
+ case $ac_sys_system in
+@@ -1241,6 +1248,10 @@ else # shared is disabled
+ LDLIBRARY='libpython$(LDVERSION).dll.a'
+ ;;
+ esac
++ case $host in
++ *-*-mingw*)
++ LDLIBRARY='libpython$(LDVERSION).a';;
++ esac
+ fi
+
+ if test "$cross_compiling" = yes; then
+@@ -2843,6 +2854,12 @@ then
+ LDCXXSHARED="g++ -shared -Wl,--enable-auto-image-base";;
+ *) LDSHARED="ld";;
+ esac
++ case $host in
++ *-*-mingw*)
++ LDSHARED='$(CC) -shared -Wl,--enable-auto-image-base'
++ LDCXXSHARED='$(CXX) -shared -Wl,--enable-auto-image-base'
++ ;;
++ esac
+ fi
+ AC_MSG_RESULT($LDSHARED)
+ LDCXXSHARED=${LDCXXSHARED-$LDSHARED}
+@@ -5670,7 +5687,8 @@ case $host in
+ dnl "errmap.h" from $srcdir/PC.
+ dnl Note we cannot use BASECPPFLAGS as autogenerated pyconfig.h
+ dnl has to be before customized located in ../PC.
+- CPPFLAGS="-I\$(srcdir)/PC $CPPFLAGS"
++ dnl (-I. at end is workaround for setup.py logic)
++ CPPFLAGS="-I\$(srcdir)/PC $CPPFLAGS -I."
+ ;;
+ esac
+
+--
+2.33.0
+