summarylogtreecommitdiffstats
path: root/0014-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch
diff options
context:
space:
mode:
authorMartchus2024-03-31 14:14:48 +0200
committerMartchus2024-03-31 14:14:48 +0200
commitbc87d5c85b8fead9f26a6c1ba8ebf42c08fad24d (patch)
tree1a523365326e5201ce4c59551f2545f8281fa1e6 /0014-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch
parent73d39ea54cd7d1558c20c40807c271b40f105732 (diff)
downloadaur-bc87d5c85b8fead9f26a6c1ba8ebf42c08fad24d.tar.gz
Update to 6.6.3
Diffstat (limited to '0014-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch')
-rw-r--r--0014-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/0014-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch b/0014-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch
new file mode 100644
index 000000000000..bf04d417efab
--- /dev/null
+++ b/0014-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch
@@ -0,0 +1,29 @@
+From 3cb82f403853a4e18280f369394fc2da36b29a01 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sat, 17 Feb 2024 20:31:12 +0100
+Subject: [PATCH 14/17] Fix errors due to disabled exceptions with cpp_winrt
+ support
+
+The winrt headers use exceptions so code using them must be compiled
+with exceptions enabled.
+
+Change-Id: I216f65b260062ff2020f8a288ddda78c3e9fc3c9
+---
+ src/plugins/platforms/windows/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/plugins/platforms/windows/CMakeLists.txt b/src/plugins/platforms/windows/CMakeLists.txt
+index ca1bbcb758c..16fd2cd2be9 100644
+--- a/src/plugins/platforms/windows/CMakeLists.txt
++++ b/src/plugins/platforms/windows/CMakeLists.txt
+@@ -9,6 +9,7 @@ qt_internal_add_plugin(QWindowsIntegrationPlugin
+ OUTPUT_NAME qwindows
+ PLUGIN_TYPE platforms
+ DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES windows
++ EXCEPTIONS
+ SOURCES
+ main.cpp
+ qtwindowsglobal.h
+--
+2.44.0
+