summarylogtreecommitdiffstats
path: root/0016-Link-corelib-correctly-against-runtimeobject-when-co.patch
diff options
context:
space:
mode:
authorMartchus2024-04-04 10:44:33 +0200
committerMartchus2024-04-04 10:44:33 +0200
commit54d151502fbdeff6b79262dc438257797d9d6cf1 (patch)
tree8436fba97826778bd16b1b8488b512c81fd9dd66 /0016-Link-corelib-correctly-against-runtimeobject-when-co.patch
parentbc87d5c85b8fead9f26a6c1ba8ebf42c08fad24d (diff)
downloadaur-54d151502fbdeff6b79262dc438257797d9d6cf1.tar.gz
Update to 6.7.0
Diffstat (limited to '0016-Link-corelib-correctly-against-runtimeobject-when-co.patch')
-rw-r--r--0016-Link-corelib-correctly-against-runtimeobject-when-co.patch45
1 files changed, 0 insertions, 45 deletions
diff --git a/0016-Link-corelib-correctly-against-runtimeobject-when-co.patch b/0016-Link-corelib-correctly-against-runtimeobject-when-co.patch
deleted file mode 100644
index 9ba902becbc8..000000000000
--- a/0016-Link-corelib-correctly-against-runtimeobject-when-co.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 31f9863d7d2228baaea7be1debf94d1e272c6768 Mon Sep 17 00:00:00 2001
-From: Martchus <martchus@gmx.net>
-Date: Sat, 17 Feb 2024 21:39:39 +0100
-Subject: [PATCH 16/17] Link corelib correctly against runtimeobject when
- compiling for Windows
-
-This library is included by mingw-w64 and also needs to be linked against
-for code in `qlocale_win.cpp` enabled via the `cpp_winrt` feature flag.
-
-Change-Id: Ie3bd0290bb2f1c0d227c60a6cf6580efddd837fd
----
- src/corelib/CMakeLists.txt | 3 +--
- .../networkinformation/networklistmanager/CMakeLists.txt | 2 +-
- 2 files changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
-index f4bd31b55d4..ba7c025d722 100644
---- a/src/corelib/CMakeLists.txt
-+++ b/src/corelib/CMakeLists.txt
-@@ -779,8 +779,7 @@ qt_internal_extend_target(Core CONDITION WIN32
- text/qlocale_win.cpp
- )
-
--# On MS-Win, clang has two flavors, one of which immitates MSVC (so claims to be it)
--qt_internal_extend_target(Core CONDITION WIN32 AND MSVC AND NOT CLANG
-+qt_internal_extend_target(Core CONDITION WIN32
- LIBRARIES
- runtimeobject
- )
-diff --git a/src/plugins/networkinformation/networklistmanager/CMakeLists.txt b/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
-index a9acc465f36..acd3754f4e5 100644
---- a/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
-+++ b/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
-@@ -14,7 +14,7 @@ qt_internal_add_plugin(QNLMNIPlugin
- Qt::NetworkPrivate
- )
-
--qt_internal_extend_target(QNLMNIPlugin CONDITION WIN32 AND MSVC AND NOT CLANG
-+qt_internal_extend_target(QNLMNIPlugin CONDITION WIN32
- LIBRARIES
- runtimeobject
- oleaut32
---
-2.44.0
-