summarylogtreecommitdiffstats
path: root/0017-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch
diff options
context:
space:
mode:
authorBjörn Bidar2023-09-20 21:55:32 +0300
committerBjörn Bidar2023-09-20 21:57:35 +0300
commitd81df13d11d918098af0991994472c172817e33e (patch)
tree9a0c027eb0c68f9cbf5076a1b489d033322191a7 /0017-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch
parenta4ae66b6b28607dd7bec51cae73300552ec8fafd (diff)
downloadaur-d81df13d11d918098af0991994472c172817e33e.tar.gz
Update to 117.0-1
- New upstream release - Use tarball instead of hg sources (missing in last change) - Patches can be found here: https://github.com/Thaodan/gecko-dev/tree/thaodan/release/117.x - Include GNOME Shell search provider Signed-off-by: Björn Bidar <bjorn.bidar@thaodan.de>
Diffstat (limited to '0017-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch')
-rw-r--r--0017-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/0017-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch b/0017-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch
new file mode 100644
index 000000000000..455e3fdb9baf
--- /dev/null
+++ b/0017-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch
@@ -0,0 +1,30 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Sat, 29 Aug 2020 22:30:59 +0200
+Subject: [PATCH] LTO: Only enable LTO for Rust when complete build uses LTO
+
+Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
+---
+ config/makefiles/rust.mk | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
+index 5d1d5470b33a4d083a846573751fbbbdbb6c249d..1071608a58130db8d006f260ea345bafdc5f9e86 100644
+--- a/config/makefiles/rust.mk
++++ b/config/makefiles/rust.mk
+@@ -82,6 +82,7 @@ endif
+ # These flags are passed via `cargo rustc` and only apply to the final rustc
+ # invocation (i.e., only the top-level crate, not its dependencies).
+ cargo_rustc_flags = $(CARGO_RUSTCFLAGS)
++ifdef MOZ_LTO
+ ifndef DEVELOPER_OPTIONS
+ ifndef MOZ_DEBUG_RUST
+ # Enable link-time optimization for release builds, but not when linking
+@@ -101,6 +102,7 @@ endif
+ endif
+ endif
+ endif
++endif
+
+ ifdef CARGO_INCREMENTAL
+ export CARGO_INCREMENTAL