summarylogtreecommitdiffstats
path: root/0023-MINGW-setup-_ssl-module.patch
diff options
context:
space:
mode:
authoratomlong2021-10-23 17:55:22 +0800
committeratomlong2021-10-23 18:06:15 +0800
commit80096c8de4b34ec1ed8f30bb428918cd592b2424 (patch)
treeb48dd1e73de9ea35a4709fb6b93deb16331ec514 /0023-MINGW-setup-_ssl-module.patch
parent89a67c05174951d172252b1db96ff93cc4ec4bcd (diff)
downloadaur-mingw-w64-python.tar.gz
update to 3.9.7
Diffstat (limited to '0023-MINGW-setup-_ssl-module.patch')
-rw-r--r--0023-MINGW-setup-_ssl-module.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/0023-MINGW-setup-_ssl-module.patch b/0023-MINGW-setup-_ssl-module.patch
new file mode 100644
index 000000000000..99a426b7b05c
--- /dev/null
+++ b/0023-MINGW-setup-_ssl-module.patch
@@ -0,0 +1,30 @@
+From 3d38194a6e0ff4c07988064d51fa10ecbf7b450d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=D0=90=D0=BB=D0=B5=D0=BA=D1=81=D0=B5=D0=B9?=
+ <alexey.pawlow@gmail.com>
+Date: Thu, 17 Jun 2021 18:51:37 +0530
+Subject: [PATCH 023/N] MINGW setup _ssl module
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Co-authored-by: Алексей <alexey.pawlow@gmail.com>
+---
+ setup.py | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/setup.py b/setup.py
+index 5466e9b..51d3f59 100644
+--- a/setup.py
++++ b/setup.py
+@@ -2386,6 +2386,8 @@ class PyBuildExt(build_ext):
+ openssl_includes = split_var('OPENSSL_INCLUDES', '-I')
+ openssl_libdirs = split_var('OPENSSL_LDFLAGS', '-L')
+ openssl_libs = split_var('OPENSSL_LIBS', '-l')
++ if MS_WINDOWS:
++ openssl_libs += tuple(['ws2_32'])
+ if not openssl_libs:
+ # libssl and libcrypto not found
+ self.missing.extend(['_ssl', '_hashlib'])
+--
+2.33.0
+