summarylogtreecommitdiffstats
path: root/0027-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch
diff options
context:
space:
mode:
authorBjörn Bidar2021-02-14 20:02:25 +0200
committerBjörn Bidar2021-02-14 22:34:41 +0200
commit9378334138de28da648bfa0644f3ea09e5c9c868 (patch)
treea3df7133d544086e60e831d592c69a9c50e71a8b /0027-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch
parent3fc7a6150487ecf4e4aba30c25d621b4581cdfd8 (diff)
downloadaur-9378334138de28da648bfa0644f3ea09e5c9c868.tar.gz
Update to 85.0.2-1
- New upstream release - Update unity-menubar patch from Ubuntu - Update firefox-kde patches from openSUSE - Rebased patches from/collected by Gentoo to improve PGO/LTO builds with GCC - Remove patch for MOZILLA#1644409 as it is committed upstream - Add patch to fix building against rust 1.50 (MOZILLA#1684261) - Move patch source description to $source to show the sources of local patches if they are not from the package itself
Diffstat (limited to '0027-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch')
-rw-r--r--0027-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/0027-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch b/0027-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch
new file mode 100644
index 000000000000..5013a6371126
--- /dev/null
+++ b/0027-LTO-Only-enable-LTO-for-Rust-when-complete-build-use.patch
@@ -0,0 +1,34 @@
+From c34b95e7a79cefedcce90739e506f4f500bc2e2b Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Sat, 29 Aug 2020 22:30:59 +0200
+Subject: [PATCH 27/39] LTO: Only enable LTO for Rust when complete build uses
+ LTO
+
+Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
+---
+ config/makefiles/rust.mk | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
+index 615d54076b..36a2e0896e 100644
+--- a/config/makefiles/rust.mk
++++ b/config/makefiles/rust.mk
+@@ -64,6 +64,7 @@ endif
+ # These flags are passed via `cargo rustc` and only apply to the final rustc
+ # invocation (i.e., only the top-level crate, not its dependencies).
+ cargo_rustc_flags = $(CARGO_RUSTCFLAGS)
++ifdef MOZ_LTO
+ ifndef DEVELOPER_OPTIONS
+ ifndef MOZ_DEBUG_RUST
+ # Enable link-time optimization for release builds, but not when linking
+@@ -77,6 +78,7 @@ RUSTFLAGS += -Cembed-bitcode=yes
+ endif
+ endif
+ endif
++endif
+
+ ifdef CARGO_INCREMENTAL
+ export CARGO_INCREMENTAL
+--
+2.30.1
+