summarylogtreecommitdiffstats
path: root/0029-Make-elfhack-use-toolchain.patch
diff options
context:
space:
mode:
authorBjörn Bidar2021-01-03 03:33:44 +0200
committerBjörn Bidar2021-01-03 16:52:48 +0200
commit7f494b67b528e2cee23db7701d8143257e742a51 (patch)
tree923c30b98a66b4257aaa7d2fcd6600bae9eac64c /0029-Make-elfhack-use-toolchain.patch
parent78eda2b6d49cfd1e5fcbeb8b68f7bb03bf049e6f (diff)
downloadaur-7f494b67b528e2cee23db7701d8143257e742a51.tar.gz
Update to 84.0.1-1
- New upstream release - Update unity-menubar patch from Ubuntu - Update firefox-kde patches from openSUSE - Drop patch to fix building against rust 1.48 as its commited upstream MOZILLA#1667736 - No longer depend on cbindgen as newer versions now work when building firefox - Rebase patches - system-sqlite - system-harfbuzz - system-graphite2 - system-dav1d - sandbox needs to be built with --param lto-partitions=1 when GCC LTO is enabled MOZILLA#1516803 - Use remoting name for GDK application names MOZILLA#1530052 - Disable elfhack - Add several patches from/collected by Gentoo to improve PGO/LTO builds with GCC - Remove old PGO patch with workarounds that are no longer required for PGP/LTO builds patch, move parts that are still needed to a patch superseding it - Use bld binutils linker instead of gold (it crashed during linking: "/usr/bin/ld.gold: internal error in set_xindex, at /build/binutils/src/binutils-gdb/gold/object.h:1007")
Diffstat (limited to '0029-Make-elfhack-use-toolchain.patch')
-rw-r--r--0029-Make-elfhack-use-toolchain.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/0029-Make-elfhack-use-toolchain.patch b/0029-Make-elfhack-use-toolchain.patch
new file mode 100644
index 000000000000..fb213cc743f3
--- /dev/null
+++ b/0029-Make-elfhack-use-toolchain.patch
@@ -0,0 +1,26 @@
+From 01459287a2dbb4d422526602a35d6d3965cffdc5 Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Mon, 28 Sep 2020 20:52:24 +0200
+Subject: [PATCH 29/35] Make elfhack use toolchain
+
+Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
+---
+ build/unix/elfhack/Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/build/unix/elfhack/Makefile.in b/build/unix/elfhack/Makefile.in
+index 08cc3d6852..c2b575d87a 100644
+--- a/build/unix/elfhack/Makefile.in
++++ b/build/unix/elfhack/Makefile.in
+@@ -20,7 +20,7 @@ test-array$(DLL_SUFFIX) test-ctors$(DLL_SUFFIX): %$(DLL_SUFFIX): %.$(OBJ_SUFFIX)
+ # Fail if the backup file doesn't exist
+ [ -f '$@.bak' ]
+ # Fail if the new library doesn't contain less relocations
+- [ $$($(TOOLCHAIN_PREFIX)objdump -R $@.bak | wc -l) -gt $$(objdump -R $@ | wc -l) ]
++ [ $$($(TOOLCHAIN_PREFIX)objdump -R $@.bak | wc -l) -gt $$($(TOOLCHAIN_PREFIX)objdump -R $@ | wc -l) ]
+
+ test-array$(DLL_SUFFIX) test-ctors$(DLL_SUFFIX): DSO_SONAME=$@
+ test-array$(DLL_SUFFIX): DT_TYPE=INIT_ARRAY
+--
+2.29.2
+