summarylogtreecommitdiffstats
path: root/003-graphite2-1.3.8-staticbuild.patch
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-01-17 17:59:27 -0300
committerGonzalo Exequiel Pedone2024-01-17 17:59:27 -0300
commit91a42ac2b2a371532cf3f7e5e8ce14774f7b3a76 (patch)
tree1eb61838c508f4b2549c5c6c7ec5e19fb17b2dae /003-graphite2-1.3.8-staticbuild.patch
downloadaur-91a42ac2b2a371532cf3f7e5e8ce14774f7b3a76.tar.gz
Package added.
Diffstat (limited to '003-graphite2-1.3.8-staticbuild.patch')
-rw-r--r--003-graphite2-1.3.8-staticbuild.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/003-graphite2-1.3.8-staticbuild.patch b/003-graphite2-1.3.8-staticbuild.patch
new file mode 100644
index 000000000000..14cbc45fb613
--- /dev/null
+++ b/003-graphite2-1.3.8-staticbuild.patch
@@ -0,0 +1,62 @@
+--- graphite2-1.3.8/src/CMakeLists.txt.orig 2016-09-17 06:30:02.570522500 -0400
++++ graphite2-1.3.8/src/CMakeLists.txt 2016-09-17 06:33:57.962672400 -0400
+@@ -106,6 +106,46 @@
+ LT_VERSION_REVISION ${GRAPHITE_API_REVISION}
+ LT_VERSION_AGE ${GRAPHITE_API_AGE})
+
++add_library(graphite2_static STATIC
++ ${GRAPHITE2_VM_TYPE}_machine.cpp
++ gr_char_info.cpp
++ gr_features.cpp
++ gr_face.cpp
++ gr_font.cpp
++ gr_logging.cpp
++ gr_segment.cpp
++ gr_slot.cpp
++ CmapCache.cpp
++ Code.cpp
++ Collider.cpp
++ Decompressor.cpp
++ Face.cpp
++ FeatureMap.cpp
++ Font.cpp
++ GlyphFace.cpp
++ GlyphCache.cpp
++ Intervals.cpp
++ Justifier.cpp
++ NameTable.cpp
++ Pass.cpp
++ Position.cpp
++ Segment.cpp
++ Silf.cpp
++ Slot.cpp
++ Sparse.cpp
++ TtfUtil.cpp
++ UtfCodec.cpp
++ ${FILEFACE}
++ ${TRACING})
++
++set_target_properties(graphite2_static PROPERTIES PUBLIC_HEADER "${GRAPHITE_HEADERS}"
++ SOVERSION ${GRAPHITE_SO_VERSION}
++ VERSION ${GRAPHITE_VERSION}
++ LT_VERSION_CURRENT ${GRAPHITE_API_CURRENT}
++ LT_VERSION_REVISION ${GRAPHITE_API_REVISION}
++ LT_VERSION_AGE ${GRAPHITE_API_AGE}
++ OUTPUT_NAME graphite2)
++
+ if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+ set_target_properties(graphite2 PROPERTIES
+ COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wendif-labels -Wshadow -Wctor-dtor-privacy -Wnon-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden -fno-stack-protector"
+@@ -148,8 +188,11 @@
+ if (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
+ set_target_properties(graphite2 PROPERTIES
+ COMPILE_DEFINITIONS "_SCL_SECURE_NO_WARNINGS;_CRT_SECURE_NO_WARNINGS;UNICODE;GRAPHITE2_EXPORTING")
++ set_target_properties(graphite2_static PROPERTIES
++ COMPILE_DEFINITIONS "_SCL_SECURE_NO_WARNINGS;_CRT_SECURE_NO_WARNINGS;UNICODE;GRAPHITE2_STATIC")
++
+ endif()
+
+
+-install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
++install(TARGETS graphite2 graphite2_static EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
+ install(EXPORT graphite2 DESTINATION share/graphite2 NAMESPACE gr2_)