summarylogtreecommitdiffstats
path: root/0040-msys-convert_path-fix-and-root-hack.patch
diff options
context:
space:
mode:
authoratomlong2021-10-23 17:55:22 +0800
committeratomlong2021-10-23 18:06:15 +0800
commit80096c8de4b34ec1ed8f30bb428918cd592b2424 (patch)
treeb48dd1e73de9ea35a4709fb6b93deb16331ec514 /0040-msys-convert_path-fix-and-root-hack.patch
parent89a67c05174951d172252b1db96ff93cc4ec4bcd (diff)
downloadaur-mingw-w64-python.tar.gz
update to 3.9.7
Diffstat (limited to '0040-msys-convert_path-fix-and-root-hack.patch')
-rw-r--r--0040-msys-convert_path-fix-and-root-hack.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/0040-msys-convert_path-fix-and-root-hack.patch b/0040-msys-convert_path-fix-and-root-hack.patch
new file mode 100644
index 000000000000..a6ddfec361b9
--- /dev/null
+++ b/0040-msys-convert_path-fix-and-root-hack.patch
@@ -0,0 +1,42 @@
+From 22fc2593de88d46a11786898d401e4801faeb125 Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Tue, 21 Sep 2021 21:18:36 +0200
+Subject: [PATCH 040/N] msys convert_path fix and root hack
+
+---
+ Makefile.pre.in | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.pre.in b/Makefile.pre.in
+index e0b8155..cf16e93 100644
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
+@@ -1707,6 +1707,12 @@ libainstall: @DEF_MAKE_RULE@ python-config
+ else true; \
+ fi
+
++ifeq ($(shell uname -o),Msys)
++DESTDIRFINAL=$(DESTDIR)
++else
++DESTDIRFINAL=$(DESTDIR)/
++endif
++
+ # Install the dynamically loadable modules
+ # This goes into $(exec_prefix)
+ sharedinstall: sharedmods
+@@ -1714,9 +1720,9 @@ sharedinstall: sharedmods
+ --prefix=$(prefix) \
+ --install-scripts=$(BINDIR) \
+ --install-platlib=$(DESTSHARED) \
+- --root=$(DESTDIR)/
+- -rm $(DESTDIR)$(DESTSHARED)/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py
+- -rm -r $(DESTDIR)$(DESTSHARED)/__pycache__
++ --root=$(DESTDIRFINAL)
++ -rm $(DESTDIRFINAL)$(DESTSHARED)/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py
++ -rm -r $(DESTDIRFINAL)$(DESTSHARED)/__pycache__
+
+ # Here are a couple of targets for MacOSX again, to install a full
+ # framework-based Python. frameworkinstall installs everything, the
+--
+2.33.0
+