summarylogtreecommitdiffstats
path: root/0077-fix-build-testinternalcapi.patch
diff options
context:
space:
mode:
authoratomlong2021-10-23 17:55:22 +0800
committeratomlong2021-10-23 18:06:15 +0800
commit80096c8de4b34ec1ed8f30bb428918cd592b2424 (patch)
treeb48dd1e73de9ea35a4709fb6b93deb16331ec514 /0077-fix-build-testinternalcapi.patch
parent89a67c05174951d172252b1db96ff93cc4ec4bcd (diff)
downloadaur-mingw-w64-python.tar.gz
update to 3.9.7
Diffstat (limited to '0077-fix-build-testinternalcapi.patch')
-rw-r--r--0077-fix-build-testinternalcapi.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/0077-fix-build-testinternalcapi.patch b/0077-fix-build-testinternalcapi.patch
new file mode 100644
index 000000000000..5bcda88bd5be
--- /dev/null
+++ b/0077-fix-build-testinternalcapi.patch
@@ -0,0 +1,28 @@
+From 08145aec08b12bed92d9010aedcf60cfcc23370b Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Thu, 17 Jun 2021 18:52:34 +0530
+Subject: [PATCH 077/N] fix build testinternalcapi
+
+---
+ setup.py | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/setup.py b/setup.py
+index 8458232..a4e6dc1 100644
+--- a/setup.py
++++ b/setup.py
+@@ -981,7 +981,11 @@ class PyBuildExt(build_ext):
+ depends=['testcapi_long.h']))
+
+ # Python Internal C API test module
++ macros = []
++ if MS_WINDOWS:
++ macros.append(('PY3_DLLNAME', 'L"%s"' % sysconfig.get_config_var('DLLLIBRARY')))
+ self.add(Extension('_testinternalcapi', ['_testinternalcapi.c'],
++ define_macros=macros,
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE']))
+
+ # Python PEP-3118 (buffer protocol) test module
+--
+2.33.0
+