summarylogtreecommitdiffstats
path: root/009-include-path.patch
diff options
context:
space:
mode:
authorYurii Kolesnykov2018-11-17 12:31:28 +0100
committerYurii Kolesnykov2018-11-17 12:31:28 +0100
commiteb76aee12ada05dfe93f6b4e108fd888f3b7d0a5 (patch)
tree5249391e353053efaedd39baf162bd648609f2fc /009-include-path.patch
downloadaur-eb76aee12ada05dfe93f6b4e108fd888f3b7d0a5.tar.gz
init,6.0.0.126642
Diffstat (limited to '009-include-path.patch')
-rw-r--r--009-include-path.patch85
1 files changed, 85 insertions, 0 deletions
diff --git a/009-include-path.patch b/009-include-path.patch
new file mode 100644
index 000000000000..845ae9df92e4
--- /dev/null
+++ b/009-include-path.patch
@@ -0,0 +1,85 @@
+diff --git a/src/VBox/HostDrivers/Support/vboxdrv/Makefile b/src/VBox/HostDrivers/Support/vboxdrv/Makefile
+index d199047..34d895f 100644
+--- a/src/VBox/HostDrivers/Support/vboxdrv/Makefile
++++ b/src/VBox/HostDrivers/Support/vboxdrv/Makefile
+@@ -131,7 +131,7 @@ ifdef VBOX_WITH_NATIVE_DTRACE
+ MOD_OBJS += SUPDrvDTrace.o
+ endif
+
+-MOD_INCL = $(addprefix -I$(KBUILD_EXTMOD),/ /include /r0drv/linux)
++MOD_INCL = $(addprefix -I$(KBUILD_EXTMOD)/vboxdrv,/ /include /r0drv/linux)
+ ifdef VBOX_WITH_NATIVE_DTRACE
+ MOD_INCL += -I/usr/include/linux -I/usr/include
+ endif
+@@ -157,7 +157,7 @@ ifdef VBOX_WITH_TEXT_MODMEM_HACK
+ endif
+
+ # build defs
+-MOD_CFLAGS = -include $(KBUILD_EXTMOD)/include/VBox/SUPDrvMangling.h \
++MOD_CFLAGS = -include $(KBUILD_EXTMOD)/vboxdrv/include/VBox/SUPDrvMangling.h \
+ -fno-omit-frame-pointer -fno-pie
+
+ include $(obj)/Makefile.include.footer
+diff --git a/src/VBox/HostDrivers/Support/vboxnetadp/Makefile b/src/VBox/HostDrivers/Support/vboxnetadp/Makefile
+index 694cb5c..8487820 100644
+--- a/src/VBox/HostDrivers/Support/vboxnetadp/Makefile
++++ b/src/VBox/HostDrivers/Support/vboxnetadp/Makefile
+@@ -34,7 +34,7 @@ MOD_OBJS += math/gcc/divdi3.o \
+ math/gcc/umoddi3.o
+ endif
+
+-MOD_INCL = $(addprefix -I$(KBUILD_EXTMOD),/ /include /r0drv/linux)
++MOD_INCL = $(addprefix -I$(KBUILD_EXTMOD)/vboxnetadp,/ /include /r0drv/linux)
+ MOD_DEFS = -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX \
+ -DRT_WITH_VBOX -DVBOX_WITH_HARDENING \
+ -Wno-declaration-after-statement
+@@ -59,6 +59,6 @@ ifdef VBOX_USE_INSERT_PAGE
+ endif
+
+ # build defs
+-MOD_CFLAGS = -include $(KBUILD_EXTMOD)/include/VBox/SUPDrvMangling.h -fno-pie
++MOD_CFLAGS = -include $(KBUILD_EXTMOD)/vboxnetadp/include/VBox/SUPDrvMangling.h -fno-pie
+
+ include $(obj)/Makefile.include.footer
+diff --git a/src/VBox/HostDrivers/Support/vboxnetflt/Makefile b/src/VBox/HostDrivers/Support/vboxnetflt/Makefile
+index e262c61..ca956d5 100644
+--- a/src/VBox/HostDrivers/Support/vboxnetflt/Makefile
++++ b/src/VBox/HostDrivers/Support/vboxnetflt/Makefile
+@@ -38,7 +38,7 @@ MOD_OBJS += math/gcc/divdi3.o \
+ math/gcc/umoddi3.o
+ endif
+
+-MOD_INCL = $(addprefix -I$(KBUILD_EXTMOD),/ /include /r0drv/linux)
++MOD_INCL = $(addprefix -I$(KBUILD_EXTMOD)/vboxnetflt,/ /include /r0drv/linux)
+ MOD_DEFS = -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 \
+ -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING \
+ -Wno-declaration-after-statement
+@@ -63,6 +63,6 @@ ifdef VBOX_USE_INSERT_PAGE
+ endif
+
+ # build defs
+-MOD_CFLAGS = -include $(KBUILD_EXTMOD)/include/VBox/SUPDrvMangling.h -fno-pie
++MOD_CFLAGS = -include $(KBUILD_EXTMOD)/vboxnetflt/include/VBox/SUPDrvMangling.h -fno-pie
+
+ include $(obj)/Makefile.include.footer
+diff --git a/src/VBox/HostDrivers/Support/vboxpci/Makefile b/src/VBox/HostDrivers/Support/vboxpci/Makefile
+index 6b3878a..7b8a8a2 100644
+--- a/src/VBox/HostDrivers/Support/vboxpci/Makefile
++++ b/src/VBox/HostDrivers/Support/vboxpci/Makefile
+@@ -38,7 +38,7 @@ MOD_OBJS += math/gcc/divdi3.o \
+ math/gcc/umoddi3.o
+ endif
+
+-MOD_INCL = $(addprefix -I$(KBUILD_EXTMOD),/ /include /r0drv/linux)
++MOD_INCL = $(addprefix -I$(KBUILD_EXTMOD)/vboxpci,/ /include /r0drv/linux)
+ MOD_DEFS = -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX \
+ -DRT_WITH_VBOX -DVBOX_WITH_HARDENING
+ ifeq ($(BUILD_TARGET_ARCH),amd64)
+@@ -60,6 +60,6 @@ ifdef VBOX_USE_INSERT_PAGE
+ endif
+
+ # build defs
+-MOD_CFLAGS = -include $(KBUILD_EXTMOD)/include/VBox/SUPDrvMangling.h -fno-pie
++MOD_CFLAGS = -include $(KBUILD_EXTMOD)/vboxpci/include/VBox/SUPDrvMangling.h -fno-pie
+
+ include $(obj)/Makefile.include.footer