summarylogtreecommitdiffstats
path: root/0091-fix-build-testinternalcapi.patch
diff options
context:
space:
mode:
authoratomlong2021-08-28 11:19:04 +0800
committeratomlong2021-08-28 13:15:13 +0800
commit89a67c05174951d172252b1db96ff93cc4ec4bcd (patch)
treed8c39fa79b201cf9aea28c51e7446a252ed8fee4 /0091-fix-build-testinternalcapi.patch
parentcf8d8d8771493a2aa8370ed323d06dc733a84181 (diff)
downloadaur-89a67c05174951d172252b1db96ff93cc4ec4bcd.tar.gz
Update to 3.9.6
Diffstat (limited to '0091-fix-build-testinternalcapi.patch')
-rw-r--r--0091-fix-build-testinternalcapi.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/0091-fix-build-testinternalcapi.patch b/0091-fix-build-testinternalcapi.patch
new file mode 100644
index 000000000000..1a3648a5f2e8
--- /dev/null
+++ b/0091-fix-build-testinternalcapi.patch
@@ -0,0 +1,28 @@
+From c7083b0b392333103cf09f4f33d66f07b0b5ac18 Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Thu, 17 Jun 2021 18:52:34 +0530
+Subject: [PATCH 091/N] fix build testinternalcapi
+
+---
+ setup.py | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/setup.py b/setup.py
+index 14e1396..0ce4714 100644
+--- a/setup.py
++++ b/setup.py
+@@ -978,7 +978,11 @@ class PyBuildExt(build_ext):
+ depends=['testcapi_long.h']))
+
+ # Python Internal C API test module
++ macros = []
++ if MS_WINDOWS:
++ macros.append(('PY3_DLLNAME', 'L"%s"' % sysconfig.get_config_var('DLLLIBRARY')))
+ self.add(Extension('_testinternalcapi', ['_testinternalcapi.c'],
++ define_macros=macros,
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE']))
+
+ # Python PEP-3118 (buffer protocol) test module
+--
+2.32.0
+