summarylogtreecommitdiffstats
path: root/01-fix-ctrtool-cxxflags.patch
diff options
context:
space:
mode:
authorangelsl2017-03-09 18:53:43 +0800
committerangelsl2017-03-09 18:58:33 +0800
commit81dddef6ea59088299bd0dcacaa9fc0579845033 (patch)
treee5b4654342216fba5e70fbf1c73e2fdd3ed76278 /01-fix-ctrtool-cxxflags.patch
parent3e03f649eb84f80cc740341162b22ee9a55a1c7c (diff)
downloadaur-81dddef6ea59088299bd0dcacaa9fc0579845033.tar.gz
Update patch for changed Makefile
Diffstat (limited to '01-fix-ctrtool-cxxflags.patch')
-rw-r--r--01-fix-ctrtool-cxxflags.patch13
1 files changed, 7 insertions, 6 deletions
diff --git a/01-fix-ctrtool-cxxflags.patch b/01-fix-ctrtool-cxxflags.patch
index 78444fad054e..06b664153899 100644
--- a/01-fix-ctrtool-cxxflags.patch
+++ b/01-fix-ctrtool-cxxflags.patch
@@ -1,12 +1,13 @@
-diff -aur pctr/ctrtool/Makefile pctr-p/ctrtool/Makefile
---- pctr/ctrtool/Makefile 2016-04-03 13:00:08.768354449 +0800
-+++ pctr-p/ctrtool/Makefile 2016-04-03 12:59:58.821687435 +0800
-@@ -4,7 +4,7 @@
+diff --git a/ctrtool/Makefile b/ctrtool/Makefile
+index 7a534c9..245eeb4 100644
+--- a/ctrtool/Makefile
++++ b/ctrtool/Makefile
+@@ -4,7 +4,7 @@ OBJS = $(foreach dir,$(SRC_DIR),$(subst .c,.o,$(wildcard $(dir)/*.c))) $(foreach
# Compiler Settings
OUTPUT = ctrtool
-CXXFLAGS = -I.
-+CXXFLAGS = -O2 -flto -Wall -I.
- CFLAGS = -O2 -flto -Wall -Wno-unused-variable -Wno-unused-result -I.
++CXXFLAGS = -O2 -Wall -I.
+ CFLAGS = -O2 -Wall -Wno-unused-variable -Wno-unused-result -I. -std=c99
CC = gcc
CXX = g++