summarylogtreecommitdiffstats
path: root/01-maynard.patch
diff options
context:
space:
mode:
authoralive4ever2016-08-23 05:43:03 +0700
committeralive4ever2016-08-23 05:43:03 +0700
commit69a78b77c4c3242d11ffad26c9d23b6bb987bc25 (patch)
tree744de28530e9a19c0cd3c6b3291a668a12f5fa64 /01-maynard.patch
parent40203921c8c1557bd25c65502d18df284889b7b0 (diff)
downloadaur-69a78b77c4c3242d11ffad26c9d23b6bb987bc25.tar.gz
Remove checkinstall function from maynard launch script
checkinstall() contains reference to build directory (ABS_BUILD). I think it's safe to remove it since makepkg doesn't forget to `make install` the package. Removing this function silences makepkg warning about reference to PKGBUILD.
Diffstat (limited to '01-maynard.patch')
-rw-r--r--01-maynard.patch21
1 files changed, 18 insertions, 3 deletions
diff --git a/01-maynard.patch b/01-maynard.patch
index 822331c8711d..ffbb278bd4a3 100644
--- a/01-maynard.patch
+++ b/01-maynard.patch
@@ -2,15 +2,30 @@ Index: b/maynard.in
===================================================================
--- a/maynard.in
+++ b/maynard.in
-@@ -1,9 +1,9 @@
+@@ -1,25 +1,12 @@
#! /bin/sh
PREFIX=@prefix@
-LIBEXECDIR=$PREFIX/libexec
-+LIBEXECDIR=@libexecdir@
- ABS_BUILDDIR=@abs_builddir@
+-ABS_BUILDDIR=@abs_builddir@
-DEFAULT_BACKGROUND=/usr/share/wallpapers/Hanami/contents/images/3872x2592.jpg
+DEFAULT_BACKGROUND=/usr/share/weston/background.png
md5() {
cat "$1" 2> /dev/null | md5sum
+ }
+
+-check_install() {
+- local_maynard="$ABS_BUILDDIR/shell/maynard"
+- installed_maynard="$LIBEXECDIR/maynard"
+- if [ ! -e "$local_maynard" -o \
+- ! -e "$installed_maynard" -o \
+- "`md5 \"$local_maynard\"`" != "`md5 \"$installed_maynard\"`" ]; then
+- echo "It looks like you forgot to run 'make install'." >&2
+- exit 1
+- fi
+-}
+-
+ mkdir ~/.config > /dev/null 2>&1
+
+ if [ -z "${MAYNARD_BACKGROUND+_}" -a \