summarylogtreecommitdiffstats
path: root/01-relocate.patch
diff options
context:
space:
mode:
authorAndrew Sun2018-11-17 09:40:13 -0500
committerAndrew Sun2018-11-17 09:40:13 -0500
commita11107f0f266e3dd7dba22be6d653da59526e236 (patch)
treef823f55ff249492b99dddbbe571e487c2c40a76e /01-relocate.patch
parent3395437391775ef65fd15cba4d5d00b355f4baf8 (diff)
downloadaur-a11107f0f266e3dd7dba22be6d653da59526e236.tar.gz
mingw-w64-hunspell: update to 1.7.0
Diffstat (limited to '01-relocate.patch')
-rw-r--r--01-relocate.patch39
1 files changed, 6 insertions, 33 deletions
diff --git a/01-relocate.patch b/01-relocate.patch
index 66587a96f4b7..86e722a84d75 100644
--- a/01-relocate.patch
+++ b/01-relocate.patch
@@ -1,41 +1,27 @@
-diff --git a/.gitignore b/.gitignore
-index 04cdd34..5ede546 100644
---- a/.gitignore
-+++ b/.gitignore
-@@ -51,7 +51,8 @@ Makefile
- /config.status
- /hunspell.pc
- /libtool
--
-+build/*
-+.vscode/*
-
- #make
- .deps/
diff --git a/src/tools/Makefile.am b/src/tools/Makefile.am
index 4c29f1a..cc25476 100644
--- a/src/tools/Makefile.am
+++ b/src/tools/Makefile.am
@@ -12,7 +12,10 @@ unmunch_SOURCES=unmunch.cxx unmunch.h
example_SOURCES=example.cxx
- example_LDADD = ../hunspell/libhunspell-1.6.la
+ example_LDADD = ../hunspell/libhunspell-1.7.la
-hunspell_SOURCES=hunspell.cxx
+hunspell_CXXFLAGS = \
+ -DBINDIR=\""$(bindir)"\" \
+ -DDATA_DIR=\""$(datadir)"\"
+hunspell_SOURCES=hunspell.cxx pathtools.cxx pathtools.hxx
+ nodist_hunspell_SOURCES= ../../config.h
hunspell_LDADD = @LIBINTL@ @LIBICONV@ ../parsers/libparsers.a \
- ../hunspell/libhunspell-1.6.la @CURSESLIB@ @READLINELIB@
-
+ ../hunspell/libhunspell-1.7.la @CURSESLIB@ @READLINELIB@
diff --git a/src/tools/hunspell.cxx b/src/tools/hunspell.cxx
index 399df86..0599794 100644
--- a/src/tools/hunspell.cxx
+++ b/src/tools/hunspell.cxx
@@ -51,6 +51,7 @@
- #include "hunspell.hxx"
- #include "csutil.hxx"
- #include "hunzip.hxx"
+ #include "../hunspell/hunspell.hxx"
+ #include "../hunspell/csutil.hxx"
+ #include "../hunspell/hunzip.hxx"
+#include "pathtools.hxx"
#define HUNSPELL_VERSION VERSION
@@ -74,19 +60,6 @@ index 399df86..0599794 100644
#define PATHSEP ";"
#ifdef __MINGW32__
-@@ -172,7 +189,12 @@ char text_conv[MAXLNLEN];
-
- #ifdef HAVE_CURSES_H
- #ifdef HAVE_NCURSESW_H
-+#ifdef __MINGW32__
-+#include <ncurses/ncurses.h>
-+#else
- #include <ncurses.h>
-+#endif //__MINGW32__
-+
- #else
- #include <curses.h>
- #endif
@@ -2042,11 +2064,20 @@ int main(int argc, char** argv) {
{
std::string path_std_str = ".";