summarylogtreecommitdiffstats
path: root/010-astc-encoder-fix-install.patch
diff options
context:
space:
mode:
authorDaniel Bermond2021-07-23 17:07:51 +0000
committerDaniel Bermond2021-07-23 17:07:51 +0000
commitb35e0e2af087b72dddabc88b7269bd03e175f5fd (patch)
tree2ab47cf486f0deb15c03e912f820fef143bdad4b /010-astc-encoder-fix-install.patch
parentf81c0ae3958a4cdf5822fcfde34701089441feac (diff)
downloadaur-b35e0e2af087b72dddabc88b7269bd03e175f5fd.tar.gz
Update to version 3.1
Diffstat (limited to '010-astc-encoder-fix-install.patch')
-rw-r--r--010-astc-encoder-fix-install.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/010-astc-encoder-fix-install.patch b/010-astc-encoder-fix-install.patch
index 32ee55f35a39..1c5f8dea1dad 100644
--- a/010-astc-encoder-fix-install.patch
+++ b/010-astc-encoder-fix-install.patch
@@ -1,19 +1,19 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -146,7 +146,7 @@ set(CMAKE_CXX_STANDARD 14)
+@@ -30,7 +30,7 @@ set(CMAKE_CXX_STANDARD 14)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)
set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
-set(PACKAGE_ROOT astcenc)
+set(PACKAGE_ROOT bin)
+
include(CTest)
- # Subcomponents
--- a/Source/UnitTest/cmake_core.cmake
+++ b/Source/UnitTest/cmake_core.cmake
-@@ -114,5 +114,3 @@ target_link_libraries(test-simd-${ISA_SIMD}
+@@ -126,4 +126,4 @@ target_link_libraries(${ASTC_TEST}
+ add_test(NAME ${ASTC_TEST}
+ COMMAND ${ASTC_TEST})
- add_test(NAME test-simd-${ISA_SIMD}
- COMMAND test-simd-${ISA_SIMD})
--
--install(TARGETS test-simd-${ISA_SIMD} DESTINATION ${PACKAGE_ROOT})
+-install(TARGETS ${ASTC_TEST} DESTINATION ${PACKAGE_ROOT})
++