summarylogtreecommitdiffstats
path: root/010-screencloud-fix-python-link-libraries.patch
diff options
context:
space:
mode:
authorDaniel Bermond2020-01-11 16:40:21 +0000
committerDaniel Bermond2020-01-13 01:12:20 +0000
commit83f6ab94760060cad1fd774b70a988bc4b9b5c54 (patch)
treefd88340b96c43730ca71b3ea364e96ae3ecf327f /010-screencloud-fix-python-link-libraries.patch
parentf6a3a951ad1b3033e56105df563403711080e9d6 (diff)
downloadaur-83f6ab94760060cad1fd774b70a988bc4b9b5c54.tar.gz
Updated to version 1.5.1
Diffstat (limited to '010-screencloud-fix-python-link-libraries.patch')
-rw-r--r--010-screencloud-fix-python-link-libraries.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/010-screencloud-fix-python-link-libraries.patch b/010-screencloud-fix-python-link-libraries.patch
new file mode 100644
index 000000000000..68dfdd82676d
--- /dev/null
+++ b/010-screencloud-fix-python-link-libraries.patch
@@ -0,0 +1,39 @@
+diff -Naurp a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2020-01-11 15:33:41.000000000 +0000
++++ b/CMakeLists.txt 2020-01-11 16:22:36.000000000 +0000
+@@ -272,17 +272,6 @@ set(REQUIRED_LIBS ${REQUIRED_LIBS}
+ ${QUAZIP_LIBRARY}
+ )
+
+-#Find Python
+-if(PYTHON_USE_PYTHON3)
+- find_package(PythonLibs 3.3 REQUIRED)
+-else(PYTHON_USE_PYTHON3)
+- find_package(PythonLibs 2.6 REQUIRED)
+-endif(PYTHON_USE_PYTHON3)
+-include_directories(${PYTHON_INCLUDE_DIR})
+-set(REQUIRED_LIBS ${REQUIRED_LIBS}
+- ${PYTHON_LIBRARIES}
+-)
+-
+ #Find PythonQt
+ find_package(PythonQt REQUIRED)
+ include_directories(${PYTHONQT_INCLUDE_DIR})
+@@ -302,6 +291,17 @@ else(PYTHONQT_QTALL_FOUND)
+ message(STATUS "Using PythonQt_QtBindings (old) for Qt bindings.")
+ endif(PYTHONQT_QTALL_FOUND)
+
++#Find Python
++if(PYTHON_USE_PYTHON3)
++ find_package(PythonLibs 3.3 REQUIRED)
++else(PYTHON_USE_PYTHON3)
++ find_package(PythonLibs 2.6 REQUIRED)
++endif(PYTHON_USE_PYTHON3)
++include_directories(${PYTHON_INCLUDE_DIR})
++set(REQUIRED_LIBS ${REQUIRED_LIBS}
++ ${PYTHON_LIBRARIES}
++)
++
+ #Platform specific libs
+ if(WIN32)
+ set(REQUIRED_LIBS ${REQUIRED_LIBS}