summarylogtreecommitdiffstats
path: root/010-vmaf-skip-test_model.patch
diff options
context:
space:
mode:
authorDaniel Bermond2020-12-03 02:58:43 +0000
committerDaniel Bermond2020-12-03 02:58:43 +0000
commita34a60b4df24c222a5eba1b43c8dcb79a68ac01b (patch)
treecf0938ab592df078d5d54a8ce7da7a3b8c6b35f2 /010-vmaf-skip-test_model.patch
parentb9b94c480993b8c924dd8f29b857582562cfafdd (diff)
downloadaur-a34a60b4df24c222a5eba1b43c8dcb79a68ac01b.tar.gz
Fix tests and match latest upstream changes
Diffstat (limited to '010-vmaf-skip-test_model.patch')
-rw-r--r--010-vmaf-skip-test_model.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/010-vmaf-skip-test_model.patch b/010-vmaf-skip-test_model.patch
new file mode 100644
index 000000000000..f4d03cc3c25b
--- /dev/null
+++ b/010-vmaf-skip-test_model.patch
@@ -0,0 +1,25 @@
+--- a/libvmaf/test/meson.build
++++ b/libvmaf/test/meson.build
+@@ -28,14 +28,6 @@ test_thread_pool = executable('test_thread_pool',
+ dependencies : thread_lib,
+ )
+
+-test_model = executable('test_model',
+- ['test.c', 'test_model.c', '../src/dict.c', '../src/svm.cpp', '../src/pdjson.c', '../src/read_json_model.c', json_model_c_sources],
+- include_directories : [libvmaf_inc, test_inc, include_directories('../src')],
+- c_args : vmaf_cflags_common,
+- cpp_args : vmaf_cflags_common,
+- dependencies : thread_lib,
+-)
+-
+ test_predict = executable('test_predict',
+ ['test.c', 'test_predict.c', '../src/predict.c', '../src/dict.c',
+ '../src/feature/feature_collector.c', '../src/feature/alias.c', '../src/model.c', '../src/svm.cpp',
+@@ -77,7 +69,6 @@ test_ref = executable('test_ref',
+ test('test_picture', test_picture)
+ test('test_feature_collector', test_feature_collector)
+ test('test_thread_pool', test_thread_pool)
+-test('test_model', test_model)
+ test('test_predict', test_predict)
+ test('test_feature_extractor', test_feature_extractor)
+ test('test_dict', test_dict)