summarylogtreecommitdiffstats
path: root/02.lto.patch
diff options
context:
space:
mode:
authorQue Quotion2016-03-21 07:06:23 +0900
committerQue Quotion2016-03-21 07:06:23 +0900
commite23a8fa281d0986b0e85569c9d3cb37c6c13e472 (patch)
treeec695876ff60f85249ada333187e2f398b9b2143 /02.lto.patch
parenta1f4bfa438fa032d98b351ce608df9cec78ab351 (diff)
downloadaur-e23a8fa281d0986b0e85569c9d3cb37c6c13e472.tar.gz
Inconsistent behavior?
Some programs say the compiler is broken when using PGO or LTO, but really they just have a particular preference for how they are fed whitespace.
Diffstat (limited to '02.lto.patch')
-rw-r--r--02.lto.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/02.lto.patch b/02.lto.patch
index f32711b58c17..056cad498c12 100644
--- a/02.lto.patch
+++ b/02.lto.patch
@@ -6,13 +6,13 @@
+ # Use lto if it is requested (check buildenv and PKGBUILD opts)
+ if check_buildoption "lto" "y" && [[ -f "$(gcc -print-search-dirs | grep install | awk '{print $2 "liblto_plugin.so"}')" ]]; then
-+ CFLAGS+="-flto=$(getconf _NPROCESSORS_ONLN)"
-+ CXXFLAGS+="-flto=$(getconf _NPROCESSORS_ONLN)"
-+ LDFLAGS+="-fuse-linker-plugin"
++ CFLAGS+=" -flto=$(getconf _NPROCESSORS_ONLN)"
++ CXXFLAGS+=" -flto=$(getconf _NPROCESSORS_ONLN)"
++ LDFLAGS+=" -fuse-linker-plugin"
+ LTOPLUGIN="$(gcc -print-search-dirs | grep install | awk '{print $2 "liblto_plugin.so"}')"
-+ ARFLAGS+="--plugin $LTOPLUGIN"
-+ RANLIBFLAGS+="--plugin $LTOPLUGIN"
-+ NMFLAGS+="--plugin $LTOPLUGIN"
++ ARFLAGS+=" --plugin $LTOPLUGIN"
++ RANLIBFLAGS+=" --plugin $LTOPLUGIN"
++ NMFLAGS+=" --plugin $LTOPLUGIN"
+ fi
+
run_function_safe "build"