summarylogtreecommitdiffstats
path: root/0200-gcc-no-exceptions.patch
diff options
context:
space:
mode:
authorWitold Kowolik2016-09-07 10:00:09 +0200
committerWitold Kowolik2016-09-07 10:00:09 +0200
commit497aeb66c80e0ce4fafca87a99788e818c0bb56b (patch)
tree93f0d306a839af10d7e01edb0b32d63cc4ad15ce /0200-gcc-no-exceptions.patch
downloadaur-497aeb66c80e0ce4fafca87a99788e818c0bb56b.tar.gz
Initial commit
Diffstat (limited to '0200-gcc-no-exceptions.patch')
-rw-r--r--0200-gcc-no-exceptions.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/0200-gcc-no-exceptions.patch b/0200-gcc-no-exceptions.patch
new file mode 100644
index 000000000000..0113bd825671
--- /dev/null
+++ b/0200-gcc-no-exceptions.patch
@@ -0,0 +1,20 @@
+--- a/libgcc/Makefile.in 2013-06-01 23:57:51.711127513 +0200
++++ b/libgcc/Makefile.in 2013-06-01 23:59:13.940660435 +0200
+@@ -492,7 +492,7 @@
+ ifeq ($(LIB2_DIVMOD_EXCEPTION_FLAGS),)
+ # Provide default flags for compiling divmod functions, if they haven't been
+ # set already by a target-specific Makefile fragment.
+-LIB2_DIVMOD_EXCEPTION_FLAGS := -fexceptions -fnon-call-exceptions
++LIB2_DIVMOD_EXCEPTION_FLAGS := -fno-exceptions -fnon-call-exceptions
+ endif
+
+ # Build LIB2_DIVMOD_FUNCS.
+@@ -813,7 +813,7 @@
+ # libgcc_eh.a, only LIB2ADDEH matters. If we do, only LIB2ADDEHSTATIC and
+ # LIB2ADDEHSHARED matter. (Usually all three are identical.)
+
+-c_flags := -fexceptions
++c_flags := -fno-exceptions
+
+ ifeq ($(enable_shared),yes)
+