summarylogtreecommitdiffstats
path: root/0200-gcc-no-exceptions.patch
diff options
context:
space:
mode:
authorWitold Kowolik2018-04-23 09:48:13 +0200
committerWitold Kowolik2018-04-23 09:48:13 +0200
commitfb9ea22f91d34d605b3329f880e565585b7bfe59 (patch)
tree545a6a2d6433fa0fa609bb81dd2d11ff1dafcecf /0200-gcc-no-exceptions.patch
downloadaur-arm-none-eabi-gcc64-linaro-alternative.tar.gz
Initial commit
Diffstat (limited to '0200-gcc-no-exceptions.patch')
-rw-r--r--0200-gcc-no-exceptions.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/0200-gcc-no-exceptions.patch b/0200-gcc-no-exceptions.patch
new file mode 100644
index 000000000000..0113bd825671
--- /dev/null
+++ b/0200-gcc-no-exceptions.patch
@@ -0,0 +1,20 @@
+--- a/libgcc/Makefile.in 2013-06-01 23:57:51.711127513 +0200
++++ b/libgcc/Makefile.in 2013-06-01 23:59:13.940660435 +0200
+@@ -492,7 +492,7 @@
+ ifeq ($(LIB2_DIVMOD_EXCEPTION_FLAGS),)
+ # Provide default flags for compiling divmod functions, if they haven't been
+ # set already by a target-specific Makefile fragment.
+-LIB2_DIVMOD_EXCEPTION_FLAGS := -fexceptions -fnon-call-exceptions
++LIB2_DIVMOD_EXCEPTION_FLAGS := -fno-exceptions -fnon-call-exceptions
+ endif
+
+ # Build LIB2_DIVMOD_FUNCS.
+@@ -813,7 +813,7 @@
+ # libgcc_eh.a, only LIB2ADDEH matters. If we do, only LIB2ADDEHSTATIC and
+ # LIB2ADDEHSHARED matter. (Usually all three are identical.)
+
+-c_flags := -fexceptions
++c_flags := -fno-exceptions
+
+ ifeq ($(enable_shared),yes)
+