summarylogtreecommitdiffstats
path: root/02_compatibility_glib-2.41.patch
diff options
context:
space:
mode:
authorJonathon Fernyhough2017-07-05 20:13:26 +0100
committerJonathon Fernyhough2017-07-05 20:18:41 +0100
commit3c9c7800ce3f679629c4bcb7ad9e9ce4e1eabba3 (patch)
treec27f2c0fd5ec0ae2ec49999ccfb4de09356a2393 /02_compatibility_glib-2.41.patch
parent5cbd981499397a21b36e7e64165b1b25e5f1c061 (diff)
downloadaur-3c9c7800ce3f679629c4bcb7ad9e9ce4e1eabba3.tar.gz
Massive overhaul for GStreamer 1.0 and GTK3.
Massive props to Debian maintainers - this PKGBUILD includes three patches lifted directly from the Debian package, with a small change to ensure python2 is used in radiotray_runner. I also switched from a source-based install to a bdist; this cuts the package size though it also means you can't link to radiotray any more (is that needed?).
Diffstat (limited to '02_compatibility_glib-2.41.patch')
-rw-r--r--02_compatibility_glib-2.41.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/02_compatibility_glib-2.41.patch b/02_compatibility_glib-2.41.patch
new file mode 100644
index 000000000000..90464cd5d3eb
--- /dev/null
+++ b/02_compatibility_glib-2.41.patch
@@ -0,0 +1,31 @@
+Description: Avoid crash during startup
+ This patch allow compatibility with the new versions of
+ glib2.0 removing gtk.gdk.threads_init() because this is now deprecated.
+Forwarded: no
+Author: Elías Alejandro Año Mendoza <ealmdz@gmail.com>
+Last-Update: 2014-09-25
+
+Index: radiotray/src/SysTray.py
+===================================================================
+--- radiotray.orig/src/SysTray.py 2014-09-25 18:15:12.000000000 -0500
++++ radiotray/src/SysTray.py 2014-09-25 18:21:49.000000000 -0500
+@@ -46,6 +46,7 @@
+ from AppIndicatorGui import AppIndicatorGui
+ from TooltipManager import TooltipManager
+ from Context import Context
++from glib import glib_version
+
+ import dbus
+ import textwrap
+@@ -182,8 +183,9 @@
+
+
+ def run(self):
+- gtk.gdk.threads_init()
+- gtk.main()
++ if glib_version < (2, 41, 0):
++ gtk.gdk.threads_init()
++ gtk.main()
+
+
+