summarylogtreecommitdiffstats
path: root/03-python.patch
diff options
context:
space:
mode:
authorhowetuft2022-03-20 10:17:53 +0100
committerhowetuft2022-03-20 10:17:53 +0100
commit19ad00d808cecb53f64ab762efca3ebede648a7c (patch)
treef1f9af874120442fdd8c9f0595ceffb9ebcf1118 /03-python.patch
parent762b3eb18b20adc7a6c8ed83b946f1f952838a69 (diff)
downloadaur-19ad00d808cecb53f64ab762efca3ebede648a7c.tar.gz
OpenImageIO v2.3
Starting from v2.3, OpenColorIO is distributed in 2 libraries. Build has to be adapted accordingly.
Diffstat (limited to '03-python.patch')
-rw-r--r--03-python.patch72
1 files changed, 72 insertions, 0 deletions
diff --git a/03-python.patch b/03-python.patch
new file mode 100644
index 000000000000..bcc15a27bc40
--- /dev/null
+++ b/03-python.patch
@@ -0,0 +1,72 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7dda21b7d..fe41ec5d8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,6 +28,10 @@ MESSAGE(STATUS "CMake version " ${CMAKE_VERSION} " detected")
+ cmake_minimum_required(VERSION 3.5.1)
+ cmake_policy(VERSION 3.0)
+
++if(POLICY CMP0072)
++ cmake_policy(SET CMP0072 OLD)
++endif()
++
+ # Remove the following when the version check is at least 2.8.4
+ SET(CMAKE_LEGACY_CYGWIN_WIN32 0)
+
+
+diff --git a/samples/luxcoreconsole/CMakeLists.txt b/samples/luxcoreconsole/CMakeLists.txt
+index 96e09bc6a..cdb83231c 100644
+--- a/samples/luxcoreconsole/CMakeLists.txt
++++ b/samples/luxcoreconsole/CMakeLists.txt
+@@ -31,5 +31,5 @@ add_executable(luxcoreconsole ${LUXCORECONSOLE_SRCS})
+ if(APPLE)
+ TARGET_LINK_LIBRARIES(luxcoreconsole expat "-framework Carbon" "-framework IOKit" ${LUXCORE_LIBRARY} ${Boost_LIBRARIES})
+ else()
+-TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
+ endif()
+diff --git a/samples/luxcoredemo/CMakeLists.txt b/samples/luxcoredemo/CMakeLists.txt
+index 194104caf..241dbd5f2 100644
+--- a/samples/luxcoredemo/CMakeLists.txt
++++ b/samples/luxcoredemo/CMakeLists.txt
+@@ -29,4 +29,4 @@ set(LUXCORELIBDEMO_SRCS
+ add_executable(luxcoredemo ${LUXCORELIBDEMO_SRCS})
+ add_definitions(${VISIBILITY_FLAGS})
+
+-TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
+diff --git a/samples/luxcorescenedemo/CMakeLists.txt b/samples/luxcorescenedemo/CMakeLists.txt
+index 3acb27bfa..b52d3ec81 100644
+--- a/samples/luxcorescenedemo/CMakeLists.txt
++++ b/samples/luxcorescenedemo/CMakeLists.txt
+@@ -29,4 +29,4 @@ set(LUXCORESCENEDEMO_SRCS
+ add_executable(luxcorescenedemo ${LUXCORESCENEDEMO_SRCS})
+ add_definitions(${VISIBILITY_FLAGS})
+
+-TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
+diff --git a/samples/luxcoreui/CMakeLists.txt b/samples/luxcoreui/CMakeLists.txt
+index 8b74e0704..c6f9c88f1 100644
+--- a/samples/luxcoreui/CMakeLists.txt
++++ b/samples/luxcoreui/CMakeLists.txt
+@@ -100,7 +100,8 @@ TARGET_LINK_LIBRARIES(luxcoreui
+ glfw
+ ${GLFW_LIBRARIES}
+ ${LUXCORE_LIBRARY}
+ ${OPENGL_LIBRARIES}
+ ${GTK3_LIBRARIES}
+- ${Boost_LIBRARIES})
++ ${Boost_LIBRARIES}
++ ${PYTHON_LIBRARIES})
+ endif()
+diff --git a/tests/luxcoreimplserializationdemo/CMakeLists.txt b/tests/luxcoreimplserializationdemo/CMakeLists.txt
+index bdd3445b8..a79c4a7b2 100644
+--- a/tests/luxcoreimplserializationdemo/CMakeLists.txt
++++ b/tests/luxcoreimplserializationdemo/CMakeLists.txt
+@@ -31,4 +31,4 @@ include_directories(${LuxRays_SOURCE_DIR}/deps/opencolorio-2.0.0/include)
+
+ add_executable(luxcoreimplserializationdemo ${LUXCOREIMPL_SERIALIZATIONDEMO_SRCS})
+
+-TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb opencolorio ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
+\ No newline at end of file
++TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})