summarylogtreecommitdiffstats
path: root/030-tensorrt-fix-python.patch
diff options
context:
space:
mode:
authorDaniel Bermond2021-03-12 01:13:23 +0000
committerDaniel Bermond2021-03-12 01:13:40 +0000
commit504651646fc5612bf8cda759cea7942d3e46506d (patch)
treee2967660931c8ff3452acfb0a26f7bbe98b583db /030-tensorrt-fix-python.patch
parent7b0a7b3d5362f79414008e579042ffe8802228d1 (diff)
downloadaur-504651646fc5612bf8cda759cea7942d3e46506d.tar.gz
Update to version 7.2.3.4
Diffstat (limited to '030-tensorrt-fix-python.patch')
-rw-r--r--030-tensorrt-fix-python.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/030-tensorrt-fix-python.patch b/030-tensorrt-fix-python.patch
index d667caacd5b4..005a85a17a2a 100644
--- a/030-tensorrt-fix-python.patch
+++ b/030-tensorrt-fix-python.patch
@@ -1,15 +1,15 @@
--- a/python/CMakeLists.txt
+++ b/python/CMakeLists.txt
-@@ -67,7 +67,7 @@ find_path(PY_CONFIG_INCLUDE pyconfig.h HINTS ${PY_INCLUDE} PATH_SUFFIXES ${PY_TA
- # Add include directories
- include_directories(${TENSORRT_ROOT}/include ${PROJECT_SOURCE_DIR}/include ${CUDA_INCLUDE_DIRS} ${PROJECT_SOURCE_DIR}/docstrings ${ONNX_INC_DIR} ${PYBIND11_DIR}/include)
+@@ -81,7 +81,7 @@ include_directories(${TENSORRT_ROOT}/include
+ )
+
# And lib directories.
-link_directories(${TENSORRT_BUILD})
+link_directories(${TENSORRT_BUILD} $ENV{TRT_NONOSS_ROOT}/lib)
# Enable link-time optimizations
set(CMAKE_CXX_FLAGS "-fvisibility=hidden -std=c++11 -flto -fno-fat-lto-objects -Wno-deprecated-declarations")
-@@ -88,6 +88,9 @@ message(STATUS "PY_CONFIG_INCLUDE: ${PY_CONFIG_INCLUDE}")
+@@ -102,6 +102,9 @@ message(STATUS "PY_CONFIG_INCLUDE: ${PY_CONFIG_INCLUDE}")
if (${CMAKE_BUILD_TYPE} STREQUAL Release)
message(STATUS "Building in Release mode")
set(TRT_LIBS nvinfer nvonnxparser nvparsers nvinfer_plugin)
@@ -33,7 +33,7 @@
- -DEXT_PATH=${EXT_PATH} \
- -DCUDA_INCLUDE_DIRS=/usr/local/cuda/include \
- -DTENSORRT_ROOT=${ROOT_PATH} \
-- -DTENSORRT_BUILD=${ROOT_PATH}/build/out
+- -DTENSORRT_BUILD=${ROOT_PATH}/build/
-make -j12
+ -DEXT_PATH="$EXT_PATH" \
+ -DCUDA_INCLUDE_DIRS='/opt/cuda/include' \