summarylogtreecommitdiffstats
path: root/06-maybe_quiet.patch
diff options
context:
space:
mode:
authorAngel Perez2021-08-06 22:08:48 -0400
committerAngel Perez2021-08-06 22:08:48 -0400
commitebd26a27644230b849bbd020e6a4d9906124aa0e (patch)
tree9f45ef35a06d46af49d6c86e508f4592655dfe1d /06-maybe_quiet.patch
parent1a29abcaf8017525d09d5b8b60bf7a2fb18895dc (diff)
downloadaur-ebd26a27644230b849bbd020e6a4d9906124aa0e.tar.gz
Solved errors in Ubuntu grub patches
Diffstat (limited to '06-maybe_quiet.patch')
-rw-r--r--06-maybe_quiet.patch88
1 files changed, 24 insertions, 64 deletions
diff --git a/06-maybe_quiet.patch b/06-maybe_quiet.patch
index 59bd82237f93..31795085556a 100644
--- a/06-maybe_quiet.patch
+++ b/06-maybe_quiet.patch
@@ -1,49 +1,3 @@
-From ec5b5793aa6befcc44bb8328a26ff34e24979b59 Mon Sep 17 00:00:00 2001
-From: Colin Watson <cjwatson@ubuntu.com>
-Date: Mon, 13 Jan 2014 12:13:26 +0000
-Subject: Add configure option to reduce visual clutter at boot time
-
-If this option is enabled, then do all of the following:
-
-Don't display introductory message about line editing unless we're
-actually offering a shell prompt. (This is believed to be a workaround
-for a different bug. We'll go with this for now, but will drop this in
-favour of a better fix upstream if somebody figures out what that is.)
-
-Don't clear the screen just before booting if we never drew the menu in
-the first place.
-
-Remove verbose messages printed before reading configuration. In some
-ways this is awkward because it makes debugging harder, but it's a
-requirement for a smooth-looking boot process; we may be able to do
-better in future. Upstream doesn't want this, though.
-
-Disable the cursor as well, for similar reasons of tidiness.
-
-Suppress kernel/initrd progress messages, except in recovery mode.
-
-Suppress "GRUB loading" message unless Shift is held down. Upstream
-doesn't want this, as it makes debugging harder. Ubuntu wants it to
-provide a cleaner boot experience.
-
-Bug-Ubuntu: https://bugs.launchpad.net/bugs/386922
-Bug-Ubuntu: https://bugs.launchpad.net/bugs/861048
-Forwarded: (partial) http://lists.gnu.org/archive/html/grub-devel/2009-09/msg00056.html
-Last-Update: 2014-01-03
-
-Patch-Name: maybe_quiet.patch
----
- config.h.in | 2 ++
- configure.ac | 16 ++++++++++++++++
- grub-core/boot/i386/pc/boot.S | 11 +++++++++++
- grub-core/boot/i386/pc/diskboot.S | 26 ++++++++++++++++++++++++++
- grub-core/kern/main.c | 17 +++++++++++++++++
- grub-core/kern/rescue_reader.c | 2 ++
- grub-core/normal/main.c | 11 +++++++++++
- grub-core/normal/menu.c | 17 +++++++++++++++--
- util/grub.d/10_linux.in | 15 +++++++++++----
- 9 files changed, 111 insertions(+), 6 deletions(-)
-
diff --git a/config.h.in b/config.h.in
index 9e8f991..d2c4ce8 100644
--- a/config.h.in
@@ -58,11 +12,12 @@ index 9e8f991..d2c4ce8 100644
/* We don't need those. */
#define MINILZO_CFG_SKIP_LZO_PTR 1
diff --git a/configure.ac b/configure.ac
+index 22663ba..d02fe6b 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1797,6 +1797,17 @@ else
- fi
- AC_SUBST([UBUNTU_RECOVERY])
+@@ -1904,6 +1904,17 @@ fi
+ AC_SUBST([LIBZFS])
+ AC_SUBST([LIBNVPAIR])
+AC_ARG_ENABLE([quiet-boot],
+ [AS_HELP_STRING([--enable-quiet-boot],
@@ -78,9 +33,9 @@ diff --git a/configure.ac b/configure.ac
LIBS=""
AC_SUBST([FONT_SOURCE])
-@@ -2048,5 +2059,10 @@ echo "Without liblzma (no support for XZ-compressed mips images) ($liblzma_excus
+@@ -2166,5 +2177,10 @@ echo "With stack smashing protector: Yes"
else
- echo "With liblzma from $LIBLZMA (support for XZ-compressed mips images)"
+ echo "With stack smashing protector: No"
fi
+if [ x"$enable_quiet_boot" = xyes ]; then
+echo With quiet boot: Yes
@@ -90,6 +45,7 @@ diff --git a/configure.ac b/configure.ac
echo "*******************************************************"
]
diff --git a/grub-core/boot/i386/pc/boot.S b/grub-core/boot/i386/pc/boot.S
+index 2bd0b2d..451c8be 100644
--- a/grub-core/boot/i386/pc/boot.S
+++ b/grub-core/boot/i386/pc/boot.S
@@ -19,6 +19,9 @@
@@ -121,6 +77,7 @@ diff --git a/grub-core/boot/i386/pc/boot.S b/grub-core/boot/i386/pc/boot.S
movw $disk_address_packet, %si
diff --git a/grub-core/boot/i386/pc/diskboot.S b/grub-core/boot/i386/pc/diskboot.S
+index c1addc0..c6fd50b 100644
--- a/grub-core/boot/i386/pc/diskboot.S
+++ b/grub-core/boot/i386/pc/diskboot.S
@@ -18,6 +18,9 @@
@@ -200,9 +157,10 @@ diff --git a/grub-core/boot/i386/pc/diskboot.S b/grub-core/boot/i386/pc/diskboot
notification_step: .asciz "."
diff --git a/grub-core/kern/main.c b/grub-core/kern/main.c
+index 73967e2..d753d81 100644
--- a/grub-core/kern/main.c
+++ b/grub-core/kern/main.c
-@@ -264,15 +264,25 @@ reclaim_module_space (void)
+@@ -265,15 +265,25 @@ reclaim_module_space (void)
void __attribute__ ((noreturn))
grub_main (void)
{
@@ -226,9 +184,9 @@ diff --git a/grub-core/kern/main.c b/grub-core/kern/main.c
grub_setcolorstate (GRUB_TERM_COLOR_STANDARD);
+#endif
- grub_load_config ();
-
-@@ -308,5 +318,12 @@ grub_main (void)
+ /* Init verifiers API. */
+ grub_verifiers_init ();
+@@ -312,5 +322,12 @@ grub_main (void)
grub_boot_time ("After execution of embedded config. Attempt to go to normal mode");
grub_load_normal_mode ();
@@ -242,6 +200,7 @@ diff --git a/grub-core/kern/main.c b/grub-core/kern/main.c
grub_rescue_run ();
}
diff --git a/grub-core/kern/rescue_reader.c b/grub-core/kern/rescue_reader.c
+index dcd7d44..03826cf 100644
--- a/grub-core/kern/rescue_reader.c
+++ b/grub-core/kern/rescue_reader.c
@@ -78,7 +78,9 @@ grub_rescue_read_line (char **line, int cont,
@@ -255,9 +214,10 @@ diff --git a/grub-core/kern/rescue_reader.c b/grub-core/kern/rescue_reader.c
while (1)
{
diff --git a/grub-core/normal/main.c b/grub-core/normal/main.c
+index c4ebe9e..f690a3f 100644
--- a/grub-core/normal/main.c
+++ b/grub-core/normal/main.c
-@@ -389,6 +389,15 @@ static grub_err_t
+@@ -407,6 +407,15 @@ static grub_err_t
grub_normal_read_line_real (char **line, int cont, int nested)
{
const char *prompt;
@@ -273,7 +233,7 @@ diff --git a/grub-core/normal/main.c b/grub-core/normal/main.c
if (cont)
/* TRANSLATORS: it's command line prompt. */
-@@ -441,7 +450,9 @@ grub_cmdline_run (int nested, int force_auth)
+@@ -459,7 +468,9 @@ grub_cmdline_run (int nested, int force_auth)
return;
}
@@ -284,6 +244,7 @@ diff --git a/grub-core/normal/main.c b/grub-core/normal/main.c
while (1)
{
diff --git a/grub-core/normal/menu.c b/grub-core/normal/menu.c
+index c2943c6..338f5a5 100644
--- a/grub-core/normal/menu.c
+++ b/grub-core/normal/menu.c
@@ -826,12 +826,18 @@ run_menu (grub_menu_t menu, int nested, int *auto_boot)
@@ -330,16 +291,18 @@ diff --git a/grub-core/normal/menu.c b/grub-core/normal/menu.c
if (auto_boot)
grub_menu_execute_with_fallback (menu, e, autobooted,
diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
+index 1839059..24acf01 100644
--- a/util/grub.d/10_linux.in
+++ b/util/grub.d/10_linux.in
-@@ -21,5 +21,6 @@ prefix="@prefix@"
+@@ -20,6 +20,7 @@ set -e
+ prefix="@prefix@"
exec_prefix="@exec_prefix@"
datarootdir="@datarootdir@"
+quiet_boot="@QUIET_BOOT@"
. "$pkgdatadir/grub-mkconfig_lib"
-@@ -148,9 +149,13 @@ linux_entry ()
+@@ -140,15 +141,21 @@ linux_entry ()
fi
printf '%s\n' "${prepare_boot_cache}" | sed "s/^/$submenu_indentation/"
fi
@@ -349,15 +312,12 @@ diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
+ message="$(gettext_printf "Loading Linux %s ..." ${version})"
+ sed "s/^/$submenu_indentation/" << EOF
echo '$(echo "$message" | grub_quote)'
-+EOF
++ EOF
+ fi
-+ sed "s/^/$submenu_indentation/" << EOF
++ sed "s/^/$submenu_indentation/" << EOF
linux ${rel_dirname}/${basename} root=${linux_root_device_thisversion} rw ${args}
EOF
if test -n "${initrd}" -o -n "${initrd_extra}" ; then
-@@ -163,8 +168,10 @@ EOF
- EOF
- if test -n "${initrd}" -o -n "${initrd_extra}" ; then
# TRANSLATORS: ramdisk isn't identifier. Should be translated.
- message="$(gettext_printf "Loading initial ramdisk ...")"
- printf ' %s\n' "echo '$(echo "$message" | grub_quote)'" | sed "s/^/$submenu_indentation/"