summarylogtreecommitdiffstats
path: root/14-fmt9.patch
diff options
context:
space:
mode:
authorbartus2023-11-23 17:35:33 +0100
committerbartus2023-11-23 17:35:33 +0100
commit77cc3dc527bacdfdd55a45edd47c8ec97196bc2b (patch)
tree86bda0e27a05459946896936d59a9ff0813015f1 /14-fmt9.patch
parente7de335e305f0a67ae8aec04dfb687a0c62a70e5 (diff)
downloadaur-77cc3dc527bacdfdd55a45edd47c8ec97196bc2b.tar.gz
Unbundle sdlog
Diffstat (limited to '14-fmt9.patch')
-rw-r--r--14-fmt9.patch107
1 files changed, 107 insertions, 0 deletions
diff --git a/14-fmt9.patch b/14-fmt9.patch
new file mode 100644
index 000000000000..77815a814f9a
--- /dev/null
+++ b/14-fmt9.patch
@@ -0,0 +1,107 @@
+From df8c3049c6b7cd822d21a18d295a8c653e153c03 Mon Sep 17 00:00:00 2001
+From: howetuft <howetuft@gmail.com>
+Date: Wed, 16 Aug 2023 20:05:05 +0200
+Subject: [PATCH 14/14] fmt9
+
+---
+ CMakeLists.txt | 3 +++
+ samples/luxcoreconsole/CMakeLists.txt | 2 +-
+ samples/luxcoredemo/CMakeLists.txt | 2 +-
+ samples/luxcorescenedemo/CMakeLists.txt | 2 +-
+ samples/luxcoreui/CMakeLists.txt | 2 +-
+ src/luxcore/CMakeLists.txt | 2 +-
+ tests/luxcoreimplserializationdemo/CMakeLists.txt | 2 +-
+ 7 files changed, 9 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c0da2b5d5..f0067dc1a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -116,6 +116,9 @@ include(Dependencies)
+ add_definitions(-DSPDLOG_FMT_EXTERNAL=1)
+ find_package(spdlog REQUIRED)
+ include_directories(${SPDLOG_INCLUDE_DIRS})
++find_package(fmt 9.0.0...<10.0.0 CONFIG)
++get_target_property(FMT_INCLUDE_DIRECTORIES fmt::fmt INTERFACE_INCLUDE_DIRECTORIES)
++include_directories(${FMT_INCLUDE_DIRECTORIES})
+
+ SET(Boost_Save ${Boost_LIBRARIES})
+ find_package(OpenVDB)
+diff --git a/samples/luxcoreconsole/CMakeLists.txt b/samples/luxcoreconsole/CMakeLists.txt
+index bd9a73651..f302c4734 100644
+--- a/samples/luxcoreconsole/CMakeLists.txt
++++ b/samples/luxcoreconsole/CMakeLists.txt
+@@ -27,7 +27,7 @@ set(LUXCORECONSOLE_SRCS
+ )
+
+ add_executable(luxcoreconsole ${LUXCORECONSOLE_SRCS})
+-find_package(fmt REQUIRED)
++find_package(fmt 9.0.0...<10.0.0 REQUIRED)
+
+ if(APPLE)
+ TARGET_LINK_LIBRARIES(luxcoreconsole expat "-framework Carbon" "-framework IOKit" ${LUXCORE_LIBRARY} ${Boost_LIBRARIES})
+diff --git a/samples/luxcoredemo/CMakeLists.txt b/samples/luxcoredemo/CMakeLists.txt
+index e2f5d114a..879929554 100644
+--- a/samples/luxcoredemo/CMakeLists.txt
++++ b/samples/luxcoredemo/CMakeLists.txt
+@@ -28,6 +28,6 @@ set(LUXCORELIBDEMO_SRCS
+
+ add_executable(luxcoredemo ${LUXCORELIBDEMO_SRCS})
+ add_definitions(${VISIBILITY_FLAGS})
+-find_package(fmt REQUIRED)
++find_package(fmt 9.0.0...<10.0.0 REQUIRED)
+
+ TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES} ${OpenVDB_LIBRARIES} fmt::fmt)
+diff --git a/samples/luxcorescenedemo/CMakeLists.txt b/samples/luxcorescenedemo/CMakeLists.txt
+index 5a010f325..389784e18 100644
+--- a/samples/luxcorescenedemo/CMakeLists.txt
++++ b/samples/luxcorescenedemo/CMakeLists.txt
+@@ -28,6 +28,6 @@ set(LUXCORESCENEDEMO_SRCS
+
+ add_executable(luxcorescenedemo ${LUXCORESCENEDEMO_SRCS})
+ add_definitions(${VISIBILITY_FLAGS})
+-find_package(fmt REQUIRED)
++find_package(fmt 9.0.0...<10.0.0 REQUIRED)
+
+ TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OpenVDB_LIBRARIES} fmt::fmt)
+diff --git a/samples/luxcoreui/CMakeLists.txt b/samples/luxcoreui/CMakeLists.txt
+index c06be0fb6..b6ff48570 100644
+--- a/samples/luxcoreui/CMakeLists.txt
++++ b/samples/luxcoreui/CMakeLists.txt
+@@ -85,7 +85,7 @@ IF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ ENDIF()
+
+ add_executable(luxcoreui ${LUXCOREUI_SRCS})
+-find_package(fmt REQUIRED)
++find_package(fmt 9.0.0...<10.0.0 REQUIRED)
+
+ if(APPLE)
+
+diff --git a/src/luxcore/CMakeLists.txt b/src/luxcore/CMakeLists.txt
+index 4a3fa76e9..f3bb5f3f4 100644
+--- a/src/luxcore/CMakeLists.txt
++++ b/src/luxcore/CMakeLists.txt
+@@ -182,7 +182,7 @@ if(APPLE)
+ target_link_libraries(pyluxcore -Wl,-undefined -Wl,dynamic_lookup slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb opencolorio expat ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
+ SET_TARGET_PROPERTIES(pyluxcore PROPERTIES XCODE_ATTRIBUTE_DEPLOYMENT_POSTPROCESSING NO) # exclude pylux from strip, not possible
+ else()
+- target_link_libraries(pyluxcore PRIVATE slg-core slg-film slg-kernels luxrays bcd opensubdiv ${OpenVDB_LIBRARIES} opencolorio ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
++ target_link_libraries(pyluxcore PRIVATE slg-core slg-film slg-kernels luxrays bcd opensubdiv ${OpenVDB_LIBRARIES} opencolorio ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} fmt::fmt)
+ endif()
+
+ set_target_properties(pyluxcore PROPERTIES PREFIX "")
+diff --git a/tests/luxcoreimplserializationdemo/CMakeLists.txt b/tests/luxcoreimplserializationdemo/CMakeLists.txt
+index 276851016..39de31bbf 100644
+--- a/tests/luxcoreimplserializationdemo/CMakeLists.txt
++++ b/tests/luxcoreimplserializationdemo/CMakeLists.txt
+@@ -30,6 +30,6 @@ include_directories(${LuxRays_SOURCE_DIR}/deps/bcd-1.1/include)
+ include_directories(${LuxRays_SOURCE_DIR}/deps/opencolorio-2.0.0/include)
+
+ add_executable(luxcoreimplserializationdemo ${LUXCOREIMPL_SERIALIZATIONDEMO_SRCS})
+-find_package(fmt)
++find_package(fmt 9.0.0...<10.0.0)
+
+ TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv opencolorio ${OpenVDB_LIBRARIES} ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} ${PYTHON_LIBRARIES} fmt::fmt)
+--
+2.41.0
+