summarylogtreecommitdiffstats
path: root/2129-fsck.ocfs2-fix-compile-error-when-glibc-upgrade.patch
diff options
context:
space:
mode:
authorNoel Kuntze2019-04-04 01:55:27 +0200
committerNoel Kuntze2019-04-04 01:55:27 +0200
commitba461ad9a5f1efbd767dd07ce716da69f4354037 (patch)
tree842530ccfd0e4ec7ccb8337195b569c2e0a889b1 /2129-fsck.ocfs2-fix-compile-error-when-glibc-upgrade.patch
parent6a8cf178892690dd8f5c5811ab31e090c234b7d5 (diff)
downloadaur-ba461ad9a5f1efbd767dd07ce716da69f4354037.tar.gz
Include fixes for compilation errors and compiling directories in parallel, add makedepends for libaio
Diffstat (limited to '2129-fsck.ocfs2-fix-compile-error-when-glibc-upgrade.patch')
-rw-r--r--2129-fsck.ocfs2-fix-compile-error-when-glibc-upgrade.patch86
1 files changed, 86 insertions, 0 deletions
diff --git a/2129-fsck.ocfs2-fix-compile-error-when-glibc-upgrade.patch b/2129-fsck.ocfs2-fix-compile-error-when-glibc-upgrade.patch
new file mode 100644
index 000000000000..9b01c1dbd3a0
--- /dev/null
+++ b/2129-fsck.ocfs2-fix-compile-error-when-glibc-upgrade.patch
@@ -0,0 +1,86 @@
+From 0ffd58b223e24779420130522ea8ee359505f493 Mon Sep 17 00:00:00 2001
+From: Gang He <ghe@suse.com>
+Date: Mon, 4 Sep 2017 14:08:59 +0800
+Subject: [PATCH 2129/2129] fsck.ocfs2: fix compile error when glibc upgrade
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+When glibc upgrade to glibc-2.26.90-14, there was a compile error in fsck.ocfs2,
+the compile error messages like,
+
+In file included from /usr/include/string.h:431:0,
+ from ../include/ocfs2/ocfs2.h:41,
+ from pass4.c:32:
+include/strings.h:37:1: error: unknown type name ‘errcode_t’; did you mean ‘mode_t’?
+ errcode_t o2fsck_strings_insert(o2fsck_strings *strings, char *string,
+ ^~~~~~~~~
+ mode_t
+---
+ fsck.ocfs2/Makefile | 2 +-
+ fsck.ocfs2/include/{strings.h => o2fsck_strings.h} | 0
+ fsck.ocfs2/pass2.c | 2 +-
+ fsck.ocfs2/pass5.c | 2 +-
+ fsck.ocfs2/strings.c | 2 +-
+ 5 files changed, 4 insertions(+), 4 deletions(-)
+ rename fsck.ocfs2/include/{strings.h => o2fsck_strings.h} (100%)
+
+diff --git a/fsck.ocfs2/Makefile b/fsck.ocfs2/Makefile
+index 051ed742..baf1994d 100644
+--- a/fsck.ocfs2/Makefile
++++ b/fsck.ocfs2/Makefile
+@@ -64,7 +64,7 @@ HFILES = include/fsck.h \
+ include/problem.h \
+ include/refcount.h \
+ include/slot_recovery.h \
+- include/strings.h \
++ include/o2fsck_strings.h \
+ include/util.h
+
+
+diff --git a/fsck.ocfs2/include/strings.h b/fsck.ocfs2/include/o2fsck_strings.h
+similarity index 100%
+rename from fsck.ocfs2/include/strings.h
+rename to fsck.ocfs2/include/o2fsck_strings.h
+diff --git a/fsck.ocfs2/pass2.c b/fsck.ocfs2/pass2.c
+index 181febb9..a48a50b5 100644
+--- a/fsck.ocfs2/pass2.c
++++ b/fsck.ocfs2/pass2.c
+@@ -43,7 +43,7 @@
+ #include "fsck.h"
+ #include "pass2.h"
+ #include "problem.h"
+-#include "strings.h"
++#include "o2fsck_strings.h"
+ #include "util.h"
+
+ static const char *whoami = "pass2";
+diff --git a/fsck.ocfs2/pass5.c b/fsck.ocfs2/pass5.c
+index 5c2d899f..bfad1b72 100644
+--- a/fsck.ocfs2/pass5.c
++++ b/fsck.ocfs2/pass5.c
+@@ -40,7 +40,7 @@
+ #include "fsck.h"
+ #include "pass5.h"
+ #include "problem.h"
+-#include "strings.h"
++#include "o2fsck_strings.h"
+ #include "util.h"
+
+ static const char *whoami = "pass5";
+diff --git a/fsck.ocfs2/strings.c b/fsck.ocfs2/strings.c
+index 4ad37822..8a7a8d9d 100644
+--- a/fsck.ocfs2/strings.c
++++ b/fsck.ocfs2/strings.c
+@@ -31,7 +31,7 @@
+ #include "ocfs2/ocfs2.h"
+
+ #include "fsck.h"
+-#include "strings.h"
++#include "o2fsck_strings.h"
+ #include "util.h"
+
+ struct string_entry {
+--
+2.14.3
+