summarylogtreecommitdiffstats
path: root/4851d4e20f66f540cd61fb69851df17671fc90d2.patch
diff options
context:
space:
mode:
authorNicola Murino2019-12-23 19:30:01 +0100
committerNicola Murino2019-12-23 19:30:01 +0100
commit5a7fe6f9b9abc8edf1309fcc471370d23101af67 (patch)
treea1441a9682e22c540a8b0ee61ac3f7878a00f5d3 /4851d4e20f66f540cd61fb69851df17671fc90d2.patch
parentdd031886c8806b0207d3d914fa0cc334d0215d7d (diff)
downloadaur-5a7fe6f9b9abc8edf1309fcc471370d23101af67.tar.gz
add needed patchs to the PKGBUILD
Diffstat (limited to '4851d4e20f66f540cd61fb69851df17671fc90d2.patch')
-rw-r--r--4851d4e20f66f540cd61fb69851df17671fc90d2.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/4851d4e20f66f540cd61fb69851df17671fc90d2.patch b/4851d4e20f66f540cd61fb69851df17671fc90d2.patch
new file mode 100644
index 000000000000..75660036f42a
--- /dev/null
+++ b/4851d4e20f66f540cd61fb69851df17671fc90d2.patch
@@ -0,0 +1,30 @@
+From 4851d4e20f66f540cd61fb69851df17671fc90d2 Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Sat, 11 May 2019 11:18:35 +0200
+Subject: [PATCH] meson: allow building a static library
+
+So that passing "-Ddefault_library=both" also creates a static lib.
+
+Note that Libs.private in the .pc file will still be wrong because of
+https://github.com/mesonbuild/meson/issues/3934 (it contains things like
+-lpixman-mmx)
+---
+ pixman/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pixman/meson.build b/pixman/meson.build
+index 6ce87e7..7b66827 100644
+--- a/pixman/meson.build
++++ b/pixman/meson.build
+@@ -97,7 +97,7 @@ pixman_files = files(
+ 'pixman-utils.c',
+ )
+
+-libpixman = shared_library(
++libpixman = library(
+ 'pixman-1',
+ [pixman_files, config_h, version_h],
+ link_with : [pixman_simd_libs],
+--
+2.24.1
+