summarylogtreecommitdiffstats
path: root/5022efe33088.patch
diff options
context:
space:
mode:
authorBjörn Bidar2021-01-03 03:33:44 +0200
committerBjörn Bidar2021-01-03 16:52:48 +0200
commit7f494b67b528e2cee23db7701d8143257e742a51 (patch)
tree923c30b98a66b4257aaa7d2fcd6600bae9eac64c /5022efe33088.patch
parent78eda2b6d49cfd1e5fcbeb8b68f7bb03bf049e6f (diff)
downloadaur-7f494b67b528e2cee23db7701d8143257e742a51.tar.gz
Update to 84.0.1-1
- New upstream release - Update unity-menubar patch from Ubuntu - Update firefox-kde patches from openSUSE - Drop patch to fix building against rust 1.48 as its commited upstream MOZILLA#1667736 - No longer depend on cbindgen as newer versions now work when building firefox - Rebase patches - system-sqlite - system-harfbuzz - system-graphite2 - system-dav1d - sandbox needs to be built with --param lto-partitions=1 when GCC LTO is enabled MOZILLA#1516803 - Use remoting name for GDK application names MOZILLA#1530052 - Disable elfhack - Add several patches from/collected by Gentoo to improve PGO/LTO builds with GCC - Remove old PGO patch with workarounds that are no longer required for PGP/LTO builds patch, move parts that are still needed to a patch superseding it - Use bld binutils linker instead of gold (it crashed during linking: "/usr/bin/ld.gold: internal error in set_xindex, at /build/binutils/src/binutils-gdb/gold/object.h:1007")
Diffstat (limited to '5022efe33088.patch')
-rw-r--r--5022efe33088.patch55
1 files changed, 22 insertions, 33 deletions
diff --git a/5022efe33088.patch b/5022efe33088.patch
index 2a2a60a7773f..d3bf3c4e55af 100644
--- a/5022efe33088.patch
+++ b/5022efe33088.patch
@@ -27,33 +27,30 @@ diff --git a/browser/installer/package-manifest.in b/browser/installer/package-m
diff --git a/build/moz.configure/old.configure b/build/moz.configure/old.configure
--- a/build/moz.configure/old.configure
+++ b/build/moz.configure/old.configure
-@@ -228,7 +228,6 @@
- '--enable-system-cairo',
- '--enable-system-extension-dirs',
- '--enable-system-pixman',
-- '--enable-system-sqlite',
- '--enable-universalchardet',
- '--enable-updater',
- '--enable-xul',
-
+@@ -103,7 +103,6 @@
+ "--enable-system-cairo",
+ "--enable-system-extension-dirs",
+ "--enable-system-pixman",
+- "--enable-system-sqlite",
+ "--enable-universalchardet",
+ "--enable-updater",
+ "--enable-xul",
diff --git a/config/external/sqlite/moz.build b/config/external/sqlite/moz.build
--- a/config/external/sqlite/moz.build
+++ b/config/external/sqlite/moz.build
-@@ -1,22 +1,18 @@
- # -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
- # vim: set filetype=python:
- # This Source Code Form is subject to the terms of the Mozilla Public
+@@ -4,19 +4,15 @@
# License, v. 2.0. If a copy of the MPL was not distributed with this
# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-if CONFIG['MOZ_SYSTEM_SQLITE']:
-+DIRS += ['../../../third_party/sqlite3/src']
-+if CONFIG['MOZ_FOLD_LIBS']:
- Library('sqlite')
-- OS_LIBS += CONFIG['SQLITE_LIBS']
+- Library('sqlite')
+- OS_LIBS += CONFIG['SQLITE_LIBS']
++DIRS += ["../../../third_party/sqlite3/src"]
++if CONFIG["MOZ_FOLD_LIBS"]:
++ Library("sqlite")
+ # When folding libraries, sqlite is actually in the nss library.
+ USE_LIBS += [
-+ 'nss',
++ "nss",
+ ]
else:
- DIRS += ['../../../third_party/sqlite3/src']
@@ -66,11 +63,11 @@ diff --git a/config/external/sqlite/moz.build b/config/external/sqlite/moz.build
- else:
- SharedLibrary('sqlite')
- SHARED_LIBRARY_NAME = 'mozsqlite3'
-+ SharedLibrary('sqlite')
-+ SHARED_LIBRARY_NAME = 'mozsqlite3'
++ SharedLibrary("sqlite")
++ SHARED_LIBRARY_NAME = "mozsqlite3"
- SYMBOLS_FILE = '/third_party/sqlite3/src/sqlite.symbols'
-+ SYMBOLS_FILE = '/third_party/sqlite3/src/sqlite.symbols'
++ SYMBOLS_FILE = "/third_party/sqlite3/src/sqlite.symbols"
diff --git a/old-configure.in b/old-configure.in
--- a/old-configure.in
+++ b/old-configure.in
@@ -168,14 +165,9 @@ diff --git a/storage/SQLiteMutex.h b/storage/SQLiteMutex.h
diff --git a/storage/moz.build b/storage/moz.build
--- a/storage/moz.build
+++ b/storage/moz.build
-@@ -93,20 +93,14 @@ FINAL_LIBRARY = 'xul'
- # Thunderbird needs the 2-argument version of fts3_tokenizer()
- if CONFIG['MOZ_THUNDERBIRD'] or CONFIG['MOZ_SUITE']:
- DEFINES['MOZ_SQLITE_FTS3_TOKENIZER'] = 1
-
- # This is the default value. If we ever change it when compiling sqlite, we
+@@ -98,12 +98,6 @@
# will need to change it here as well.
- DEFINES['SQLITE_MAX_LIKE_PATTERN_LENGTH'] = 50000
+ DEFINES["SQLITE_MAX_LIKE_PATTERN_LENGTH"] = 50000
-# See Sqlite moz.build for reasoning about TEMP_STORE.
-# For system sqlite we cannot use the compile time option, so we use a pragma.
@@ -184,11 +176,8 @@ diff --git a/storage/moz.build b/storage/moz.build
- DEFINES['MOZ_MEMORY_TEMP_STORE_PRAGMA'] = True
-
LOCAL_INCLUDES += [
- '/dom/base',
- '/third_party/sqlite3/src',
- ]
-
- CXXFLAGS += CONFIG['SQLITE_CFLAGS']
+ "/dom/base",
+ "/third_party/sqlite3/src",
diff --git a/storage/mozStorageConnection.cpp b/storage/mozStorageConnection.cpp
@@ -750,10 +749,6 @@ nsresult Connection::initializeInternal(
return convertResultCode(srv);