summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Grousset/tuxayo2021-07-08 01:27:01 +0200
committerVictor Grousset/tuxayo2021-07-08 01:27:01 +0200
commit74d74dd2337d4a970c9d90a6bf9e6674b54924e4 (patch)
treeabe3ab71cf0d73f2227652bd016d067f4d12e233
parentd2b8a1197e33c02e53e279d438f9361eeb2dedca (diff)
downloadaur-74d74dd2337d4a970c9d90a6bf9e6674b54924e4.tar.gz
More details about debug symbols kept + simplify debug build comments
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e51539202be..6b970bdbbee9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,8 +17,13 @@ depends=('binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'libvorbis'
makedepends=('boost' 'cmake' 'mesa' 'zip' 'python2' 'libsm' 'git')
source=("git+https://github.com/0ad/0ad.git")
md5sums=('SKIP')
-# keep debug symbols, it shouldn't have a signicant binary size impact
+
options=(!strip)
+# Keep debug symbols, it shouldn't have a signicant binary size impact.
+# To use them, run with a debugger the actual 0ad executable.
+# Example with gdb:
+# - standard build: `gdb pyrogenesis`
+# - debug build: `gdb pyrogenesis_dbg` (keep reading to learn about the debug build)
pkgver() {
cd ${srcdir}/${_pkgname}
@@ -42,18 +47,16 @@ build() {
cd "$srcdir/${_pkgname}/libraries/source/fcollada/src"
make -j9
- # OPTIONAL: uncomment for a debug build, it's a 2nd executable name
+ # OPTIONAL: uncomment for a debug build, it's a 2nd executable named
# `pyrogenesis_dbg` It's a small increase of build time.
+ # There is something else to uncomment below in package_0ad-git()
# It's independent from the debug symbols and not as important as them.
# https://trac.wildfiregames.com/wiki/Debugging#CallstackonLinuxmacOS
# make config=debug -j9
cd "$srcdir/${_pkgname}/build/workspaces/gcc"
make -j9
- # OPTIONAL: uncomment for a debug build, it's a 2nd executable name
- # `pyrogenesis_dbg` It's a small increase of build time.
- # It's independent from the debug symbols and not as important as them.
- # https://trac.wildfiregames.com/wiki/Debugging#CallstackonLinuxmacOS
+ # OPTIONAL: uncomment for a debug build, see above
# make config=debug -j9
}
@@ -69,8 +72,11 @@ package_0ad-git() {
install -Dm755 binaries/system/pyrogenesis "${pkgdir}/usr/bin"
# OPTIONAL: uncomment debug build. See the comments around the `make` calls
# install -Dm755 binaries/system/pyrogenesis_dbg "${pkgdir}/usr/bin"
+
install -Dm755 binaries/system/*.so "${pkgdir}/usr/lib/${_pkgname}"
+
install -Dm755 build/resources/${_pkgname}.sh "${pkgdir}/usr/bin/${_pkgname}"
+
install -Dm644 build/resources/${_pkgname}.desktop \
"${pkgdir}/usr/share/applications/${_pkgname}.desktop"
install -Dm644 build/resources/${_pkgname}.png \