summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfusion8092016-09-14 10:59:20 +1000
committerfusion8092016-09-14 10:59:20 +1000
commit7a469b6baa6c56bd821b0eddd754a5dceb993c9a (patch)
tree8887572d028b2913f2d977b5ee1ca90ae50e6687
parent306889eaa017d99790346793c37bccf3eb8bfe7e (diff)
downloadaur-7a469b6baa6c56bd821b0eddd754a5dceb993c9a.tar.gz
Updating
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
-rw-r--r--tmpfixgcsegfault3.patch52
3 files changed, 81 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d857398daf1..f984a4c420eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,6 @@
# Generated by mksrcinfo v8
-# Tue Sep 13 06:01:24 UTC 2016
+# Wed Sep 14 00:59:20 UTC 2016
pkgbase = 0ad-git
- pkgdesc = Cross-platform, 3D and historically-based real-time strategy game — built from git source tree. WARNING: the 0ad git repo is 2.7 GB in size!
pkgver = 18069
pkgrel = 1
url = http://play0ad.com/
@@ -34,10 +33,16 @@ pkgbase = 0ad-git
depends = miniupnpc
depends = icu
depends = nspr
- provides = 0ad
- conflicts = 0ad
source = git+https://github.com/0ad/0ad.git
md5sums = SKIP
pkgname = 0ad-git
+ pkgdesc = Cross-platform, 3D and historically-based real-time strategy game — built from git source tree. WARNING: the 0ad git repo is 2.7 GB in size!
+ provides = 0ad
+ conflicts = 0ad
+
+pkgname = 0ad-data-git
+ pkgdesc = Data package for 0ad built from source code. WARNING: the 0ad git repo is 2.7 GB in size!
+ provides = 0ad-data
+ conflicts = 0ad-data
diff --git a/PKGBUILD b/PKGBUILD
index 8a64b68ab54a..98cb2555e9c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,12 @@
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: t3ddy <t3ddy1988 "at" gmail {dot} com>
# Contributor: Adrián Chaves Fernández (Gallaecio) <adriyetichaves@gmail.com>
-pkgname=0ad-git
+pkgname=('0ad-git' '0ad-data-git')
_pkgname=0ad
pkgver=18069
pkgrel=1
-pkgdesc="Cross-platform, 3D and historically-based real-time strategy game — built from git source tree. WARNING: the 0ad git repo is 2.7 GB in size!"
arch=('i686' 'x86_64')
url="http://play0ad.com/"
-conflicts=('0ad')
-provides=('0ad')
license=('GPL2' 'CCPL')
depends=('binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'libvorbis'
'libxml2' 'openal' 'sdl2' 'wxgtk' 'zlib' 'libgl' '0ad-data' 'glu'
@@ -28,6 +25,7 @@ pkgver() {
prepare() {
cd "$srcdir/${_pkgname}"
sed -i "s/env python/env python2/g" libraries/source/cxxtest-4.4/bin/cxxtestgen
+# patch -Np1 -i "$srcdir/tmpfixgcsegfault3.patch"
}
build() {
@@ -40,23 +38,35 @@ build() {
--libdir=/usr/lib/0ad \
--datadir=/usr/share/${pkgname}/data
- cd "$srcdir/${_pkgname}/build/workspaces/gcc"
+ cd "$srcdir/${_pkgname}/libraries/source/fcollada/src"
+ make
+ cd "$srcdir/${_pkgname}/build/workspaces/gcc"
make
}
-package() {
- install -d "${pkgdir}"/usr/{bin,lib/${_pkgname},share/"${_pkgname}"/data}
+package_0ad-git() {
+ pkgdesc="Cross-platform, 3D and historically-based real-time strategy game — built from git source tree. WARNING: the 0ad git repo is 2.7 GB in size!"
+ conflicts=('0ad')
+ provides=('0ad')
+
+ install -d "${pkgdir}"/usr/{bin,lib/${_pkgname}}
cd "$srcdir/${_pkgname}"
install -Dm755 binaries/system/pyrogenesis "${pkgdir}/usr/bin"
install -Dm755 binaries/system/*.so "${pkgdir}/usr/lib/${_pkgname}"
-
- cp -r binaries/data/l10n/ ${pkgdir}/usr/share/${_pkgname}/data/
-
install -Dm755 build/resources/${_pkgname}.sh "${pkgdir}/usr/bin/${_pkgname}"
install -Dm644 build/resources/${_pkgname}.desktop \
"${pkgdir}/usr/share/applications/${_pkgname}.desktop"
install -Dm644 build/resources/${_pkgname}.png \
"${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
}
+
+package_0ad-data-git() {
+ pkgdesc="Data package for 0ad built from source code. WARNING: the 0ad git repo is 2.7 GB in size!"
+ conflicts=('0ad-data')
+ provides=('0ad-data')
+
+ mkdir -p ${pkgdir}/usr/share/${_pkgname}
+ cp -r ${srcdir}/${_pkgname}/binaries/data ${pkgdir}/usr/share/${_pkgname}
+}
diff --git a/tmpfixgcsegfault3.patch b/tmpfixgcsegfault3.patch
new file mode 100644
index 000000000000..563a97e0ae6a
--- /dev/null
+++ b/tmpfixgcsegfault3.patch
@@ -0,0 +1,52 @@
+Index: libraries/source/spidermonkey/FixGCSegfault.diff
+===================================================================
+--- libraries/source/spidermonkey/FixGCSegfault.diff (nonexistent)
++++ libraries/source/spidermonkey/FixGCSegfault.diff (working copy)
+@@ -0,0 +1,16 @@
++diff --git a/js/src/configure b/js/src/configure
++--- a/js/src/configure
+++++ b/js/src/configure
++@@ -8776,11 +8776,11 @@ if test "$GNU_CC"; then
++ if test -z "$DEVELOPER_OPTIONS"; then
++ CFLAGS="$CFLAGS -ffunction-sections -fdata-sections"
++ CXXFLAGS="$CXXFLAGS -ffunction-sections -fdata-sections"
++ fi
++ CFLAGS="$CFLAGS -fno-math-errno"
++- CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-math-errno"
+++ CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-math-errno -fno-delete-null-pointer-checks"
++ fi
++
++
++ # Check whether --enable-icf or --disable-icf was given.
++ if test "${enable_icf+set}" = set; then
+Index: libraries/source/spidermonkey/patch.sh
+===================================================================
+--- libraries/source/spidermonkey/patch.sh (revision 18693)
++++ libraries/source/spidermonkey/patch.sh (working copy)
+@@ -14,15 +14,15 @@ patch -p1 < ../FixZLibMozBuild.diff
+ # This patch is a squashed version of several patches that were adapted
+ # to fix failing hunks.
+ #
+ # Applied in the following order, they are:
+ # * https://bugzilla.mozilla.org/show_bug.cgi?id=1223767
+-# Assertion failure: i < size_, at js/src/vm/TraceLoggingTypes.h:210
++# Assertion failure: i < size_, at js/src/vm/TraceLoggingTypes.h:210
+ # Also fix stop-information to make reduce.py work correctly.
+ # * https://bugzilla.mozilla.org/show_bug.cgi?id=1227914
+ # Limit the memory tracelogger can take.
+-# This causes tracelogger to flush data to the disk regularly and prevents out of
++# This causes tracelogger to flush data to the disk regularly and prevents out of
+ # memory issues if a lot of data gets logged.
+ # * https://bugzilla.mozilla.org/show_bug.cgi?id=1155618
+ # Fix tracelogger destructor that touches possibly uninitialised hash table.
+ # * https://bugzilla.mozilla.org/show_bug.cgi?id=1223636
+ # Don't treat extraTextId as containing only extra ids.
+@@ -46,5 +46,8 @@ patch -p1 < ../FixZLibMozBuild.diff
+ # * https://bugzilla.mozilla.org/show_bug.cgi?id=1259403
+ # Only increase capacity by multiples of 2.
+ # Always make sure there are 3 free slots for events.
+ # ===
+ patch -p1 < ../FixTracelogger.diff
++
++# Temporary fix for segfault occurring in the GC when built with GCC 6
++patch -p1 < ../FixGCSegfault.diff