summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpeeweep2020-06-03 05:23:24 +0000
committerpeeweep2020-06-03 13:23:24 +0800
commit921c11a4fd0137a3b46f222a80a6ea59a0f50a70 (patch)
tree3c88d2e18a6c2f741da9afcb832e56b3bd104ad7
downloadaur-921c11a4fd0137a3b46f222a80a6ea59a0f50a70.tar.gz
0.0.23
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91711c1f6885
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = 0ad-zh-lang
+ pkgdesc = Chinese Fonts and Translations For 0ad
+ pkgver = a23.1
+ pkgrel = 1
+ url = https://play0ad.com/
+ arch = any
+ license = GPL
+ depends = 0ad=a23.1
+ depends = 0ad-data=a23.1
+ source = 0ad-zh-lang-0.0.23.zip::http://releases.wildfiregames.com/locales/zh-lang-0.0.23.pyromod
+ sha256sums = ef668ca135541eb7dea787fbe219b1496d958c4a0392398dabdd3bb1ff7be217
+
+pkgname = 0ad-zh-lang
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4c616fe992d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+0ad-zh-lang-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b0d2664ee66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: peeweep <peeweep at 0x0 dot ee>
+
+pkgname=0ad-zh-lang
+pkgver=a23.1
+_pkgver=0.0.23
+pkgrel=1
+pkgdesc="Chinese Fonts and Translations For 0ad"
+arch=(any)
+url="https://play0ad.com/"
+license=('GPL')
+depends=(0ad=${pkgver} 0ad-data=${pkgver})
+source=(${pkgname}-${_pkgver}.zip::"http://releases.wildfiregames.com/locales/zh-lang-${_pkgver}.pyromod")
+sha256sums=('ef668ca135541eb7dea787fbe219b1496d958c4a0392398dabdd3bb1ff7be217')
+
+package() {
+ install -d 644 ${pkgdir}/usr/share/0ad/data/mods/public
+ cp -r ${srcdir}/fonts ${pkgdir}/usr/share/0ad/data/mods/public/
+ cp -r ${srcdir}/l10n ${pkgdir}/usr/share/0ad/data/mods/public/
+ cp -r ${srcdir}/mod.json ${pkgdir}/usr/share/0ad/data/mods/public/
+}
+
+# vim:set ts=2 sw=2 et: