summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Band2017-06-06 15:22:45 +0200
committerRicardo Band2017-06-06 15:22:45 +0200
commit34abe83dece30f745e2ef580c28699c9fa76a8c3 (patch)
tree09cd3197b7475d955267d3008658313fa0a1824b
parent48b7e9b9a78575029cc9f0c650a8b8e2ae4ed5c7 (diff)
downloadaur-34abe83dece30f745e2ef580c28699c9fa76a8c3.tar.gz
now compiling the binary
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86cb98f6dbac..0f5c4771f406 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,10 +4,11 @@ pkgbase = 0xff
pkgrel = 1
url = https://github.com/xengi/0xff
install = 0xff.install
- arch = x86_64
+ arch = any
license = MIT
- source = https://github.com/XenGi/0xff/releases/download/v1.1.0/0xff
- sha256sums = ab79535ec5e56484f0c1a845a185a2555aaa8f998c4d7744f6d62a2ae8b11c14
+ makedepends = go
+ source = git+https://github.com/XenGi/0xff#tag=v1.1.0
+ sha256sums = SKIP
pkgname = 0xff
diff --git a/PKGBUILD b/PKGBUILD
index 6638b43c6eee..72283bea66f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,22 @@ pkgname=0xff
pkgver=1.1.0
pkgrel=1
pkgdesc="Simple http(s) file sharing tool. Think 'python -m http.server' but better."
-arch=('x86_64')
+arch=('any')
url='https://github.com/xengi/0xff'
license=('MIT')
-source=("https://github.com/XenGi/0xff/releases/download/v${pkgver}/0xff")
-sha256sums=('ab79535ec5e56484f0c1a845a185a2555aaa8f998c4d7744f6d62a2ae8b11c14')
+source=("git+https://github.com/XenGi/0xff#tag=v${pkgver}")
+sha256sums=('SKIP')
install='0xff.install'
+makedepends=('go')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ go build 0xff.go
+}
package() {
- cd "${srcdir}"
+ cd "${srcdir}/${pkgname}"
install -Dm 755 0xff "${pkgdir}/usr/bin/0xff"
- install -Dm 644 ../nginx.conf "${pkgdir}/usr/share/0xff/nginx.conf"
- install -Dm 644 ../0xff.service "${pkgdir}/usr/lib/systemd/system/0xff.service"
+ install -Dm 644 ../../nginx.conf "${pkgdir}/usr/share/0xff/nginx.conf"
+ install -Dm 644 ../../0xff.service "${pkgdir}/usr/lib/systemd/system/0xff.service"
}