summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAudun-Marius Gangstø2022-05-30 11:46:17 +0800
committerAudun-Marius Gangstø2022-05-30 11:46:17 +0800
commit462b13aaf31d1ed8fa40aef3cc14b8f19d138276 (patch)
treef85eed8535ddec549f32384cabfae230400cacab
downloadaur-462b13aaf31d1ed8fa40aef3cc14b8f19d138276.tar.gz
Initial effort
-rw-r--r--.SRCINFO22
-rw-r--r--123.sh30
-rw-r--r--PKGBUILD60
3 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b81c0fabe43e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = 123-bin
+ pkgdesc = Lotus 1-2-3 for Unix release 3.0
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://github.com/taviso/123elf
+ arch = i386
+ license = unknown
+ makedepends = unzip
+ makedepends = cpio
+ makedepends = gcc
+ makedepends = binutils
+ depends = lib32-ncurses
+ provides = 123
+ noextract = 123-unix.zip
+ source = 123-bin::git+https://github.com/taviso/123elf.git
+ source = https://archive.org/compress/123-unix/formats=ISO%20IMAGE&file=/123-unix.zip
+ source = 123.sh
+ sha256sums = SKIP
+ sha256sums = ff6e43b904c1611d13baaf6d33df9ccf0ab2153025fbd384ca17ffd16c525e29
+ sha256sums = 02774d899d22c3ea807b5065e6ade1285eb5da175588507a4f047e65bce409b5
+
+pkgname = 123-bin
diff --git a/123.sh b/123.sh
new file mode 100644
index 000000000000..4ef34dfb4bfc
--- /dev/null
+++ b/123.sh
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+# Setup wrapper for 123 since setup123 isn't working
+
+setupfile="$HOME/.l123set"
+
+
+if ! [ -e "$setupfile" ]; then
+ echo -n "
+Since this is the first time you're running 123, settings is being copied for you into $setupfile.
+
+You can edit this as you see fit.
+
+Press return to continue"
+ read;
+ cat <<EOF > "$setupfile"
+1001 Lotus 1-2-3 Version "10"
+1002 Base Directory "/usr/share/lotus/"
+1003 Printer Interface "lpr -o dest={dest} {file}"
+1004 Graphics Driver "dumb" "ega egas25cc.vbd"
+1007 Help Language "USA English" "USA-English"
+1011 Display Char. Set "US ASCII" "l_ascii.bun"
+1005 Country Driver "USA-English Numbers First" "l13cUSF3.cbd"
+1006 Resource Language "USA English" "USA-English"
+1012 File Character Set "US ASCII" "l_ascii.bun"
+1008 File Name Mode "UNIX file name mode" "0"
+1010 Keyboard "xterm"
+EOF
+fi
+exec /usr/share/lotus/bin/123.bin $@
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8c86736d8db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Audun-Marius Gangstø <audun@gangsto.org>
+pkgname=123-bin
+pkgver=3.0
+pkgrel=1
+epoch=
+pkgdesc="Lotus 1-2-3 for Unix release 3.0"
+arch=("i386")
+url="https://github.com/taviso/123elf"
+license=('unknown')
+groups=()
+depends=("lib32-ncurses")
+makedepends=('unzip' 'cpio' 'gcc' 'binutils')
+checkdepends=()
+optdepends=()
+provides=('123')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}::git+https://github.com/taviso/123elf.git"
+"https://archive.org/compress/123-unix/formats=ISO%20IMAGE&file=/123-unix.zip"
+"123.sh"
+)
+noextract=('123-unix.zip')
+sha256sums=(
+ 'SKIP'
+ 'ff6e43b904c1611d13baaf6d33df9ccf0ab2153025fbd384ca17ffd16c525e29'
+ '02774d899d22c3ea807b5065e6ade1285eb5da175588507a4f047e65bce409b5'
+ )
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname"
+ unzip -n ../123-unix.zip
+ y | ./extract.sh
+}
+
+build() {
+ cd "$pkgname"
+ ./binutils.sh || true
+ make
+}
+
+check() {
+ cd "$pkgname"
+ make -k check
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ install -D -m755 "123" "$pkgdir/usr/share/lotus/bin/123.bin"
+ install -D -m755 "../123.sh" "$pkgdir/usr/bin/123"
+ gzip -kf root/lotus/man/man1/123.1
+ install -D -m644 root/lotus/man/man1/123.1.gz "$pkgdir/usr/share/man/man1/123.1.gz"
+ install -d "$pkgdir/usr/share/lotus"
+ cp -r "root/lotus/123.v10" "$pkgdir/usr/share/lotus/"
+}