summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAudun-Marius Gangstø2022-05-30 11:59:03 +0800
committerAudun-Marius Gangstø2022-05-30 11:59:03 +0800
commit8e08acc29f28756f206d7abb8119020d5387b313 (patch)
treebd51fa35e8e2faea63f2210e046f6c65e5c7038d
parent462b13aaf31d1ed8fa40aef3cc14b8f19d138276 (diff)
downloadaur-8e08acc29f28756f206d7abb8119020d5387b313.tar.gz
archive.org archives are different every time so checksums fail
-rw-r--r--PKGBUILD24
1 files changed, 19 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8c86736d8db..84c3d4e33b83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgver=3.0
pkgrel=1
epoch=
pkgdesc="Lotus 1-2-3 for Unix release 3.0"
-arch=("i386")
+arch=("i386" "i686" "x86_64")
url="https://github.com/taviso/123elf"
license=('unknown')
groups=()
@@ -20,20 +20,34 @@ options=()
install=
changelog=
source=("${pkgname}::git+https://github.com/taviso/123elf.git"
-"https://archive.org/compress/123-unix/formats=ISO%20IMAGE&file=/123-unix.zip"
+"https://archive.org/download/123-unix/123UNIX1.IMG"
+"https://archive.org/download/123-unix/123UNIX2.IMG"
+"https://archive.org/download/123-unix/123UNIX3.IMG"
+"https://archive.org/download/123-unix/123UNIX4.IMG"
+"https://archive.org/download/123-unix/123UNIX5.IMG"
"123.sh"
)
-noextract=('123-unix.zip')
+noextract=(
+'123UNIX1.IMG'
+'123UNIX2.IMG'
+'123UNIX3.IMG'
+'123UNIX4.IMG'
+'123UNIX5.IMG'
+)
sha256sums=(
'SKIP'
- 'ff6e43b904c1611d13baaf6d33df9ccf0ab2153025fbd384ca17ffd16c525e29'
+ '09996c4e8e33f83cacbde257ad4b04ca6b1432102b1d6eef28e64bdf5d6b7315'
+ '4bdc6559105fbf9e2237b06a896b2ea34ecadef086bdc08b1ee2b4928ad51239'
+ '336a30d68115b4f2a51c8aee4605b5f95d7bfd22e43c6a5779b9938563929f87'
+ '5a2fdc33cde7056522aa47740460cd44873e4b8c3bb4d3891b06610e95dd4218'
+ '444d28234594436334231aaa06431bee3323ce7e300ba8e7c62fe16c87c11681'
'02774d899d22c3ea807b5065e6ade1285eb5da175588507a4f047e65bce409b5'
)
validpgpkeys=()
prepare() {
+ cp 123UNIX1.IMG 123UNIX2.IMG 123UNIX3.IMG 123UNIX4.IMG 123UNIX5.IMG "$pkgname"/
cd "$pkgname"
- unzip -n ../123-unix.zip
y | ./extract.sh
}