summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Luna2023-07-14 01:05:35 -0600
committerChristopher Luna2023-07-14 01:05:35 -0600
commit0491da1762fbcac5a20e70c68116b4760f8fd4e1 (patch)
treedc065005916a3fbef75866689239c72912030384
downloadaur-0491da1762fbcac5a20e70c68116b4760f8fd4e1.tar.gz
First
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD49
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11d2c8fad8c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = 123elf
+ pkgdesc = Native port of Lotus 1-2-3 to Linux.
+ pkgver = 1.0.0rc4
+ pkgrel = 1
+ url = https://github.com/taviso/123elf
+ arch = i686
+ arch = x86_64
+ license = custom
+ noextract = binutils-2.38.tar.xz
+ noextract = 123UNIX1.IMG
+ noextract = 123UNIX2.IMG
+ noextract = 123UNIX3.IMG
+ noextract = 123UNIX4.IMG
+ noextract = 123UNIX5.IMG
+ source = https://github.com/taviso/123elf/archive/refs/tags/v1.0.0rc4.tar.gz
+ source = https://archive.org/download/123-unix/123UNIX1.IMG
+ source = https://archive.org/download/123-unix/123UNIX2.IMG
+ source = https://archive.org/download/123-unix/123UNIX3.IMG
+ source = https://archive.org/download/123-unix/123UNIX4.IMG
+ source = https://archive.org/download/123-unix/123UNIX5.IMG
+ source = https://ftp.gnu.org/gnu/binutils/binutils-2.38.tar.xz
+ md5sums = c1d56afbf72353cfc8b1e478dbbb5bb2
+ md5sums = b759a30d019b5c7ae221f6119ff6c821
+ md5sums = d0dba12e243b6d1f2ee8f27cb0a5c986
+ md5sums = aaf8adb12d5915f443b0754ebf0a98d3
+ md5sums = 1752432abf4951589386db4f8ace4c92
+ md5sums = 0965e866b299af5046ec7973e7157211
+ md5sums = 6e39cad1bb414add02b5b1169c18fdc5
+
+pkgname = 123elf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17ed1a30834d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: chrisl echo archlinux@c2h0r1i2s4t5o6p7h8e9r-l3u4n1a.com|sed 's/[0-9]//g'
+
+pkgname=123elf
+pkgver=1.0.0rc4
+pkgrel=1
+pkgdesc="Native port of Lotus 1-2-3 to Linux."
+url="https://github.com/taviso/123elf"
+depends=()
+arch=('i686' 'x86_64')
+license=('custom')
+source=(https://github.com/taviso/$pkgname/archive/refs/tags/v$pkgver.tar.gz
+ https://archive.org/download/123-unix/123UNIX1.IMG
+ https://archive.org/download/123-unix/123UNIX2.IMG
+ https://archive.org/download/123-unix/123UNIX3.IMG
+ https://archive.org/download/123-unix/123UNIX4.IMG
+ https://archive.org/download/123-unix/123UNIX5.IMG
+ https://ftp.gnu.org/gnu/binutils/binutils-2.38.tar.xz
+)
+md5sums=('c1d56afbf72353cfc8b1e478dbbb5bb2'
+ 'b759a30d019b5c7ae221f6119ff6c821'
+ 'd0dba12e243b6d1f2ee8f27cb0a5c986'
+ 'aaf8adb12d5915f443b0754ebf0a98d3'
+ '1752432abf4951589386db4f8ace4c92'
+ '0965e866b299af5046ec7973e7157211'
+ '6e39cad1bb414add02b5b1169c18fdc5')
+noextract=(binutils-2.38.tar.xz
+ 123UNIX1.IMG
+ 123UNIX2.IMG
+ 123UNIX3.IMG
+ 123UNIX4.IMG
+ 123UNIX5.IMG
+)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ln -s ../../123UNIX1.IMG .
+ ln -s ../../123UNIX2.IMG .
+ ln -s ../../123UNIX3.IMG .
+ ln -s ../../123UNIX4.IMG .
+ ln -s ../../123UNIX5.IMG .
+ ln -s ../../binutils-2.38.tar.xz .
+ CFLAGS="" CPPFLAGS="" LDFLAGS="" ./binutils.sh
+ ./extract.sh
+ make
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install prefix="$pkgdir"/usr/
+}