summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Dressel2021-04-12 20:38:55 +0000
committerJames Dressel2021-04-12 20:38:55 +0000
commit92c933d06eaee0836bdd662cb8e27ffd57f65770 (patch)
tree3a45c6de5c8caf8a29de867a40f851638f5a8640
parent90f7a615a694eaebb541887c361ea17300124b1a (diff)
parent253c246e341d81f86bde65290caac39513e1899f (diff)
downloadaur-92c933d06eaee0836bdd662cb8e27ffd57f65770.tar.gz
Merge branch 'release/8.0.33-26.BETA' into 'master'
upgpkg: 1password 8.0.33-26.BETA See merge request dev/core/1password-archlinux-aur!26
-rw-r--r--.SRCINFO12
-rwxr-xr-x1password.install34
-rw-r--r--PKGBUILD21
3 files changed, 39 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e1890b04a1b..5efffe0e1da8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = 1password
pkgdesc = Password manager and secure wallet
- pkgver = 8.0.32
- pkgrel = 1
+ pkgver = 8.0.33_26.BETA
+ pkgrel = 26
url = https://1password.com
install = 1password.install
arch = x86_64
license = LicenseRef-1Password-Proprietary
depends = hicolor-icon-theme
options = !strip
- source = https://downloads.1password.com/linux/tar/1password-8.0.32.tar.gz
- source = https://downloads.1password.com/linux/tar/1password-8.0.32.tar.gz.sig
+ source = https://downloads.1password.com/linux/tar/1password-8.0.33-26.BETA.tar.gz
+ source = https://downloads.1password.com/linux/tar/1password-8.0.33-26.BETA.tar.gz.sig
validpgpkeys = 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
- sha256sums = 78e207b4e70d4fff86e71eb3300c543427fc993263611bad20bd5e74a481cbe9
- sha256sums = 78760f2c792c6a46af8139ac75ff3f2a9ab96c6f1dac6967c7ce9be61dd287d8
+ sha256sums = 2cbcdd3ab34aeea04fbdfcb286c3b425c7cd35d4726abd21ac1e1ca5ee142b6c
+ sha256sums = f2d40812bb474adc915490e8232e61a321609188e26a918b0a49aed6f8f7ffb8
pkgname = 1password
diff --git a/1password.install b/1password.install
index 4f90d35b7a3f..0449d8769b4b 100755
--- a/1password.install
+++ b/1password.install
@@ -9,6 +9,22 @@ app_group_exists() {
fi
}
+set_chromesandbox_permissions() {
+ # chrome-sandbox requires the setuid bit to be specifically set.
+ # See https://github.com/electron/electron/issues/17972
+ chmod 4755 /opt/1Password/chrome-sandbox
+}
+
+setup_browser_helper() {
+ # Setup the Core App Integration helper binary with the correct permissions and group
+ HELPER_PATH="/opt/1Password/1Password-KeyringHelper"
+
+ chgrp "${GROUP_NAME}" $HELPER_PATH
+ # The binary requires setuid so it may interact with the Kernel keyring facilities
+ chmod u+s $HELPER_PATH
+ chmod g+s $HELPER_PATH
+}
+
pre_install() {
if app_group_exists; then
: # Do nothing
@@ -26,23 +42,13 @@ pre_upgrade() {
}
post_install() {
- # Setup the Core App Integration helper binary with the correct permissions and group
- HELPER_PATH="/opt/1Password/1Password-KeyringHelper"
-
- chgrp "${GROUP_NAME}" $HELPER_PATH
- # The binary requires setuid so it may interact with the Kernel keyring facilities
- chmod u+s $HELPER_PATH
- chmod g+s $HELPER_PATH
+ set_chromesandbox_permissions
+ setup_browser_helper
}
post_upgrade() {
- # Setup the Core App Integration helper binary with the correct permissions and group
- HELPER_PATH="/opt/1Password/1Password-KeyringHelper"
-
- chgrp "${GROUP_NAME}" $HELPER_PATH
- # The binary requires setuid so it may interact with the Kernel keyring facilities
- chmod u+s $HELPER_PATH
- chmod g+s $HELPER_PATH
+ set_chromesandbox_permissions
+ setup_browser_helper
}
post_remove() {
diff --git a/PKGBUILD b/PKGBUILD
index 4b7107a26cab..a75f26e0c167 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
pkgname=1password
-_tarver=8.0.32
+
+_tarver=8.0.33-26.BETA
_tar="${pkgname}-${_tarver}.tar.gz"
pkgver=${_tarver//-/_}
-pkgrel=1
+pkgrel=26
pkgdesc="Password manager and secure wallet"
arch=('x86_64')
url='https://1password.com'
@@ -11,8 +12,8 @@ depends=('hicolor-icon-theme')
options=(!strip)
install="${pkgname}.install"
source=(https://downloads.1password.com/linux/tar/${_tar}{,.sig})
-sha256sums=('78e207b4e70d4fff86e71eb3300c543427fc993263611bad20bd5e74a481cbe9'
- '78760f2c792c6a46af8139ac75ff3f2a9ab96c6f1dac6967c7ce9be61dd287d8'
+sha256sums=('2cbcdd3ab34aeea04fbdfcb286c3b425c7cd35d4726abd21ac1e1ca5ee142b6c'
+ 'f2d40812bb474adc915490e8232e61a321609188e26a918b0a49aed6f8f7ffb8'
)
validpgpkeys=('3FEF9748469ADBE15DA7CA80AC2D62742012EA22')
@@ -21,16 +22,20 @@ package() {
cd "${pkgname}-${_tarver}"
# Install icons
- icons=(usr/share/icons/hicolor/*/${pkgname}.png)
- for icon in "${icons[@]}"
+ resolutions=(32x32 64x64 256x256 512x512)
+ for resolution in "${resolutions[@]}"
do
- install -Dm0644 "${icon}" "${pkgdir}/${icon}"
+ install -Dm0644 "resources/icons/hicolor/${resolution}/apps/${pkgname}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${resolution}/apps/${pkgname}.png"
done
# Install desktop file
- install -Dm0644 usr/share/applications/${pkgname}.desktop -t "${pkgdir}"/usr/share/applications/
+ install -Dm0644 resources/${pkgname}.desktop -t "${pkgdir}"/usr/share/applications/
# Install system unlock PolKit policy file
install -Dm0644 com.1password.1Password.policy -t "${pkgdir}"/usr/share/polkit-1/actions/
+ # Install examples
+ install -Dm0644 resources/custom_allowed_browsers -t "${pkgdir}"/usr/share/doc/${pkgname}/examples/
+
# Move package contents to /opt/1Password
cd "${srcdir}"
install -dm0755 "${pkgdir}"/opt