summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchLinux Release Bot2022-07-20 13:58:26 +0000
committerArchLinux Release Bot2022-07-20 13:58:26 +0000
commitc287f519c753e1ab9a0f9cb94a8160aecc91ebc9 (patch)
treef52cc842c41bf2860fe882fc8a8ad67c572d0d27
parent68d832b905efda042058db99b16289766bc881bd (diff)
downloadaur-c287f519c753e1ab9a0f9cb94a8160aecc91ebc9.tar.gz
upgpkg: 1password 8.8.0
-rw-r--r--.SRCINFO12
-rwxr-xr-x1password.install8
-rw-r--r--PKGBUILD12
3 files changed, 14 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a95ff6658fe6..abaf389d6509 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 1password
pkgdesc = Password manager and secure wallet
- pkgver = 8.7.3
- pkgrel = 2
+ pkgver = 8.8.0
+ pkgrel = 203
url = https://1password.com
install = 1password.install
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = 1password
conflicts = 1password-beta
conflicts = 1password-beta-bin
options = !strip
- source = https://downloads.1password.com/linux/tar/stable/x86_64/1password-8.7.3.x64.tar.gz
- source = https://downloads.1password.com/linux/tar/stable/x86_64/1password-8.7.3.x64.tar.gz.sig
+ source = https://downloads.1password.com/linux/tar/stable/x86_64/1password-8.8.0.x64.tar.gz
+ source = https://downloads.1password.com/linux/tar/stable/x86_64/1password-8.8.0.x64.tar.gz.sig
validpgpkeys = 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
- sha256sums = d4931250a6dea9ccb3e5224bacf0fd91aa9294f234a5954c5c58d1b8c22fc2aa
- sha256sums = 71e3ee2da7fdd57187303f62046653c9c5e6b893ae115b419e46bc0d0eb5010a
+ sha256sums = c6c0e016e2e1823b2dd84e02ba61403f75ab3d9456b2858d7bf360f159ef9be5
+ sha256sums = 30443cf33e80753082ab858282328863349f0a977fa51ef5faaded5b955ce5e5
pkgname = 1password
depends = hicolor-icon-theme
diff --git a/1password.install b/1password.install
index e752514a5c66..156badc2ee65 100755
--- a/1password.install
+++ b/1password.install
@@ -9,12 +9,6 @@ app_group_exists() {
fi
}
-set_chromesandbox_permissions() {
- # chrome-sandbox requires the setuid bit to be specifically set.
- # See https://github.com/electron/electron/issues/17972
- chmod 4755 /opt/1Password/chrome-sandbox
-}
-
setup_browser_helper() {
# Setup the Core App Integration helper binary with the correct permissions and group
HELPER_PATH="/opt/1Password/1Password-KeyringHelper"
@@ -46,12 +40,10 @@ pre_upgrade() {
}
post_install() {
- set_chromesandbox_permissions
setup_browser_helper
}
post_upgrade() {
- set_chromesandbox_permissions
setup_browser_helper
}
diff --git a/PKGBUILD b/PKGBUILD
index 65efb4af4e97..296521956e90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
pkgname=1password
-_tarver=8.7.3
+_tarver=8.8.0
_tar="1password-${_tarver}.x64.tar.gz"
pkgver=${_tarver//-/_}
-pkgrel=2
+pkgrel=203
conflicts=('1password-beta' '1password-beta-bin')
pkgdesc="Password manager and secure wallet"
arch=('x86_64')
@@ -12,8 +12,8 @@ license=('LicenseRef-1Password-Proprietary')
options=(!strip)
install="1password.install"
source=(https://downloads.1password.com/linux/tar/stable/${CARCH}/${_tar}{,.sig})
-sha256sums=('d4931250a6dea9ccb3e5224bacf0fd91aa9294f234a5954c5c58d1b8c22fc2aa'
- '71e3ee2da7fdd57187303f62046653c9c5e6b893ae115b419e46bc0d0eb5010a'
+sha256sums=('c6c0e016e2e1823b2dd84e02ba61403f75ab3d9456b2858d7bf360f159ef9be5'
+ '30443cf33e80753082ab858282328863349f0a977fa51ef5faaded5b955ce5e5'
)
validpgpkeys=('3FEF9748469ADBE15DA7CA80AC2D62742012EA22')
@@ -59,4 +59,8 @@ EOF" > ./com.1password.1Password.policy
# Symlink /usr/bin executable to opt
install -dm0755 "${pkgdir}"/usr/bin
ln -s /opt/1Password/1password "${pkgdir}"/usr/bin/1password
+
+ # chrome-sandbox requires the setuid bit to be specifically set.
+ # See https://github.com/electron/electron/issues/17972
+ chmod 4755 "${pkgdir}"/opt/1Password/chrome-sandbox
}