summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Chevalier2017-03-10 05:34:09 +0000
committerPierre Chevalier2017-03-10 05:34:21 +0000
commit21ef97670e8d0630db3646dc10eb49629e7aca19 (patch)
tree63a62709ccf8a6c64fad7b68000ee8f975274cf0
parente0ec90695af7fe6a56c9b283dddf252526eee47e (diff)
downloadaur-21ef97670e8d0630db3646dc10eb49629e7aca19.tar.gz
Update to version 0.5 (with more fancy colours)
Also rename installed executable to 2048 for convenience
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00f233d33997..7d697237f9bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = 2048-rs
- pkgdesc = A cli implementation of the popular 2048 game written in rust
- pkgver = 0.4.0
+ pkgdesc = A very pretty cli implementation of the popular 2048 game written in rust
+ pkgver = 0.5.0
pkgrel = 1
url = https://github.com/pierrechevalier83/2048
arch = i686
arch = x86_64
license = MIT
makedepends = cargo
- source = 2048-rs-0.4.0.tar.gz::https://crates.io/api/v1/crates/game-2048/0.4.0/download
- sha256sums = 73ab1f3ffa49e5149774358ffd9f0ad0bec0e6f18644f72436650dc53226e0f7
+ source = 2048-rs-0.5.0.tar.gz::https://crates.io/api/v1/crates/game-2048/0.5.0/download
+ sha256sums = 7b4c6bb8bc283427b2faac0817c0d14dcf97a04c07436f76076b941be7ddb07d
pkgname = 2048-rs
diff --git a/PKGBUILD b/PKGBUILD
index ce2d542e4204..779ef5cac601 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=2048-rs
_pkgname=game-2048
-pkgver=0.4.0
+pkgver=0.5.0
pkgrel=1
-pkgdesc="A cli implementation of the popular 2048 game written in rust"
+pkgdesc="A very pretty cli implementation of the popular 2048 game written in rust"
url="https://github.com/pierrechevalier83/2048"
makedepends=('cargo')
arch=('i686' 'x86_64')
license=('MIT')
source=("$pkgname-$pkgver.tar.gz::https://crates.io/api/v1/crates/$_pkgname/$pkgver/download")
-sha256sums=('73ab1f3ffa49e5149774358ffd9f0ad0bec0e6f18644f72436650dc53226e0f7')
+sha256sums=('7b4c6bb8bc283427b2faac0817c0d14dcf97a04c07436f76076b941be7ddb07d')
build() {
cd "$_pkgname-$pkgver"
@@ -19,5 +19,5 @@ build() {
package() {
cd "$_pkgname-$pkgver"
- install -Dm755 target/release/game-2048 "$pkgdir/usr/bin/2048-rs"
+ install -Dm755 target/release/game-2048 "$pkgdir/usr/bin/2048"
}