summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2015-06-08 10:47:09 -1000
committerGaetan Bisson2015-06-08 10:47:09 -1000
commit6fa5a63f26a73386ce0f80e5300d73daf2163f2c (patch)
tree98ac75e86caa4d9cf42129b37f3162425dea246d
downloadaur-6fa5a63f26a73386ce0f80e5300d73daf2163f2c.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..134f7d190d8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = 2048.c-git
+ pkgdesc = Console version of the game "2048" for GNU/Linux
+ pkgver = 20150412.c9bba68
+ pkgrel = 1
+ url = https://github.com/mevdschee/2048.c
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ license = custom:MIT
+ makedepends = git
+ provides = 2048.c
+ conflicts = 2048.c
+ source = 2048.c::git+https://github.com/mevdschee/2048.c.git
+ sha1sums = SKIP
+
+pkgname = 2048.c-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60af817e7b4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: sekret
+
+_pkgname=2048.c
+pkgname=${_pkgname}-git
+pkgver=20150412.c9bba68
+pkgrel=1
+pkgdesc='Console version of the game "2048" for GNU/Linux'
+url='https://github.com/mevdschee/2048.c'
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+license=('custom:MIT')
+makedepends=('git')
+source=("${_pkgname}::git+https://github.com/mevdschee/2048.c.git")
+sha1sums=('SKIP')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}"
+ ./2048 test
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 2048 "${pkgdir}/usr/bin/2048"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}